We are working on it... (fix)

Howdy folks! Support has reached out to let us know some users have seen the
error pop up when accessing 3D Warehouse from within SketchUp. One possible fix
is to log out and then back in. Sometimes the system just forgets who its talking to.
If that doesn’t help, let us know.
Happy Sketching!


I get this from my Firefox browser also. Instead of making users jump through uselss hoops, how about fixing your buggy site?

I tried logging out - 3D Warehouse still opens as a blank page. Any updates on this issue?

That’s curious. Everything looks back to normal on my end. Can you try different browsers and incognito mode?

I have tried Safari, Google and Bing in incognito mode - same issue. Tried restarting my Mac, logging into Trimble account “incognito” and opening Sketchup - still no 3D Warehouse; just a big blank page staring back at me.

1 Like

Try going to myaccount.trimble.com check rhe ‘My Products’ section on the left, then ‘View Included Apps’ and search the 3D Warehouse app-launch button.

1 Like

One of the first things I tried. When I click on 3D Warehouse Launch it opens to a page that takes forever to finally tell me the following:

We are working on it…

We are completing some maintenance, sorry for any inconvenience.

Feel free to visit our forums and thank you for your patience and understanding.

SketchUp Status Page

I can not access either the 3D warehouse !
Any help thanks

Ok! Excellent troubleshooting! One last question. Can you try the following:

  1. Take your cellphone off of your Wifi network (so that it is only using cellular data)
  2. go to https://3dwarehouse.sketchup.com/ on your phone
    Let me know what comes back.

Did as you asked. Using LTE connection on my cel, 3D warehouse did open right up. What are you thinking this means?

So, I’m feeling this is somehow network related… something blocking the traffic. Could be a work VPN, or an overzealous ad blocker / network security system. You could also try attaching your computer to your phone via hotspot and IF it works we have eliminated security systems installed on your computer and can start looking at VPN, Router, etc.

1 Like

Set iMac to use cel hotspot and could not open 3D Warehouse. I am using Xfinity’s internet service - have been for many years. I have seen no other anomalies with my Mac and internet other than this one. Haven’t downloaded any new OS or browser updates lately.

Ok, and in theory your phone attached to your wifi network will still be able to reach https://3dwarehouse.sketchup.com/
IF NOT, then it could be a combination of things causing the issue; both network and system.
But, I doubt that’s the case. Some folks had reported an issue related to Xfinity, so let’s keep that in mind.

IF your phone is able to reach https://3dwarehouse.sketchup.com/ while on your wifi network it would allow us to point the issue back to something on the computer.
I also have a mac. But, I’m not experiencing the access issues with Chrome or Safari.
It seems unlikely that the issue is cookie or extension related because you stated that you got the same outcome with all of your browsers. Unless you’re experiencing cookie issues on all of your browsers (also unlikely).
A couple of additional questions. Do you have a VPN or antivirus installed on your Mac? Lastly, what model mac are you using and what OS version?

1 Like

No VPN. (I know I should)
No antiV other than what might come with Safari - if any.

iMac (Retina 5K, 27-inch, 2017)
Radeon Pro 580 8 GB

OS 10.15.7 (19H1519)

It’s probably been 4-5 weeks since I searched for a model on Warehouse. It worked then. Again, nothing hardware or software has changed for me since then.

Ok. That MacOS release is from late 2019. Not pointing my finger at it as the culprit, but something to consider.

Interestingly, I’ve got a similar issue with some of my work websites. Something is up with my network (probably my PiHole ad blocker) that only allows me full access if I’m on my company’s VPN. I know I’m an edge case because most of my coworkers don’t have that problem and I don’t have the time to dig in to my settings to fix it. THAT being said, I would be interested in seeing if you see a difference while on a VPN. You probably know how they work but in a nutshell, it essentially puts your computer on someone else’s network and bypasses your local network configuration. In this case you could install something like TunnelBear on your Chrome browser, switch to another network and THEN see if you can access 3D Warehouse.

A follow up to the previous message. Are you able to see 3D Warehouse from your phone WHILE it is on your wifi network? (probably ‘yes’)

When I returned to my office my phone connected to office internet and I could still scroll through Warehouse. A newbie, but would connecting via private browser through Safari or Google as you suggested earlier offer a similar result to using VPN or is that only affecting my computer’s browser history.

Great! Thanks for the follow up on the phone / wifi question. Your answer leads me to think that your network is not the issue, but it’s possibly the way your computer is handling its network traffic.

(And, to everyone reading, this is something I would usually do in a private message, but I figured the steps we are taking could be valuable to more than just Archted.)

Now let’s talk about private browsing versus VPN. Private browsing really just tells your web browser to put on a blindfold… You don’t know who I am, you can forget my cookies and my history… that kind of stuff. The VPN actually creates a virtual network tunnel. Your browser knows who you are but it’s like your computer is on an entirely different network. All the network traffic now happens on that outside network, like you’ve moved your computer to a new location.

1 Like

Why the sudden shift to not allowing me to open Warehouse? Seems so arbitrary. With no changes on my end or SketchUp’s end should I be speaking with Xfinity about this? Probably like speaking to an insurance provider about a medical issue.

TunnelBear the best (see least expensive) VPN option going right now?

I can’t think of any changes we may have made that could cause this. Slight chance of a technology change / update / patch that has happened that is not well understood by browers without the latest updates, but who knows. I do know, however, that this isn’t a mass outage or technology break because my inbox is relatively quiet.

As for speaking with Xfinity, using a VPN will essentially get you off of Xfinity’s network in a manner of speaking. I had suggested TunnelBear because there is a free version AND it’s relatively easy to install / uninstall. Feel free to use any trial you like, since we are only doing this as an experiment.

1 Like

TunnelBear VPN is VPNing. Went to my opened Trimble account and clicked on the “Launch” for Warehouse - wa-wa-wa, same result. Same notification about there being a problem that is being worked on.

I am left handed - probably not the cause but just in case.

Should I shut down the computer and restart? Zap the PRAM? Stand on one foot?