Warehouse Model is Invisible - Not Hidden Geometry

I downloaded a bathtub from the 3D warehouse, and when I went to put it in my model all I could see was the wireframe boundary box - no geometry inside. I clicked to place it and it disappeared. I have tried turning on “View hidden objects” and “view hidden geometry” and nothing shows up. I know it’s still in my model because I can see it in Enscape (idk if any of you use Enscape) - please see the screenshot attached.

Any ideas as to how I can get it visible and delete it? Thanks in advance!
Screenshot 2021-02-03 134820|690x388

If you want to remove it, go to Outliner. Find the component, select it, and hit Delete. Remember to purge unused afterward.

Can you share the .skp file so we can try to help you sort out why it doesn’t show?

That worked, thank you!

I couldn’t upload my file. I don’t know if it’s too large? (66 MB)

1 Like

When you have large files like that you can upload them to Drop Box and share the link.

Since you’ve deleted the tub now, can you share the 3D Warehouse name of the tub so we can take a look at the component?

FWIW, maybe it would be a good idea to go to Window>Model Info>Statistics and click Purge Unused.

I purged unused, thanks.

This is the component: Fiberglass Tub & Shower Surround

Did that reduce the file size by much?

Is this the component?
Screenshot - 2_3_2021 , 3_09_59 PM

If you have Profiles turned off and face style set to Hidden Line, this thing would disappear because it edges are all softened or hidden. Here I have Shadows turned on. Without them it would be visible at all.

Another thing to check in your model is that your model is correctly dimensioned. The component seem to be the model at the right size but if your model is drawn larger than life size, the shower might not be visible at all. Recently a new user was having problems with components not showing up. As it turned out they had created the model such that the building was over 1000 miles tall.

The file is still just as big.

Yes, that’s the component. The line/face settings issue would make sense, except for I have my face style set to “Shaded with Textures”.

And my model is correctly dimensioned, so that’s not the issue.

Well, I guess without seeing your model it’s pretty difficult to give you more that a guess.

That’s understandable. But anyway, thanks for your help!

1 Like

I’m going to guess you have a layer/tag issue.
But again without seeing it…