How to remove geometry from Warehouse model

Hi,
Can anyone please suggest another way to hide geometry in a 3dWarehouse model? I cannot seem to hide the geometry by clicking ‘View/Hidden Geometry’ and selecting or unselecting the option. I’m using SketchUp Pro 2020. This is the model I’d like to use:


Thanks in advance :slight_smile:

That doesn’t appear to be hidden geometry, you need to use Soften/Smooth to make it hidden.

Thank you SO much. So simple. Sorted. I really appreciate your help!