Eliminating Hidden Geometry

I am having trouble eliminating hidden geometry in the attached model. Any help?
ADU.4119.skp (817.1 KB)

I just created a new topic in reply to your post in the Welcome thread.

Your model seems to be rotated (or it has been modeled) with what needs to be vertical now being horizontal. If so, reset the drawing axes and rotate your model making vertical aligned with the systems blue axis.

As for deleting hidden geometry:

  • first get rid of all these the terrible guides (click ‘Delete Guide’)

  • Uncheck ‘Hidden Geometry’ to make invisible

  • Select all ( [Ctrl] + [A] )

  • next check ‘Hidden Geometry’ to turn on its visibliity

  • next use the window selection (left to right) to select all while holding down [SHIFT] to deselect what was previously selected but now to select all hidden geometry

  • hit [Del] to delete your selection, which is only all hidden geometry.


Yes, thanks for this, but, for me, when I hit [Del] to delete the hidden geometry, I end up deleting the hidden geometry ( hidden lines for me ) and the polygons within those lines end up getting deleted too. Please help. Thanks

You can’t just delete hidden geometry, it’s what holds everything together. The specific issue in this thread was stray hidden geometry.

So what is your specific issue.
Images and models help us help you.

Thanks, for the help.
I have seen SketchUp models with sphere without those black lines. I want to create models like that with smooth surfaces but I have no idea how these people do it. Apparently, they do not even have hidden lines to cover up those ugly black lines.

Image above is what is was like.

I want it to be like it without the lines which I can achieve by making lines hidden.

Anyways, thanks for the help

You can soften/smooth those edges either with the softening slider or by using the eraser tool with ctrl. Eraser with shift will hide the edge leaving the corner still sharp.
The underlying edges have to remain and you will see them as a dotted line if you turn on the view of hidden geometry.

Just to explain a little more since you mentioned a sphere.
Everything is made of flat faces, even a sphere is made of multiple flat polygons.
As you see here the sphere when the edges are unsoftened shows as a faceted ball, when softened it looks smooth but the underlying hidden structure is still there, without it it can’t exist.
Hidden Structure

1 Like

Thank you very much! :smile:

However, I was attempting to use the soften/smoothen tool whilst having the model selected but instead of softening/smoothing those black lines, it does nothing. So, if I can’t take a shortcut which seemed to be intended, do I have to manually right-click each and every line, and soften/smooth it?

Thanks again for the help rendered! :+1:

Do you have the geometry selected or just a group or component?

If you share the .skp file you are working with it would be a lot easier to see what you’ve got and help you get it sorted out.

1 Like

I’ve tried with both, having the selected geometry in a group and a component. Neither seemed to work. In edit group/component, I selected all and click Soften/Smooth Edges, but did nothing. I selected the group/component and clicked Soften/Smooth Edges, but neither did it work. Even with a group/component, it still would not work.

And, I’ve tried it on more than one .skp file, so, I’ve no clue how to do this…

Click the glasses icon on the right toolbar and adjust the softening options.