Vray's Lighting not working properly

Hi. I’m having problem about lighting in Vray. Specifically, my spotlight doesn’t work, even when I already enabled them in assets editor. I’ve some other lights in the scene but all of them work, except for the spotlight associated with the Downlight model.
Pics for references:
Sketchup Model

Vray Render

I’m using Sketchup Pro 2021
I’m new to Sketchup and Vray overall, so I can’t troubleshoot to see what’s happened to my light. Can someone please have a look? This is my skp file. Much appreciated!

P/s: My model is heavy because I don’t know how to optimize the file. So sorry for this.

To optimize the file size, always purge your model before save it.

use extension “purge all” will make it easier

https://sketchucation.com/pluginstore?pln=PurgeAll

btw, as i use sketchup 2020, i cant examine your models. if you can reupload it after save as to older sketchup version, i’ll be happy to check it

regards
iwan

1 Like

Thanks for the reply.

I’m using CleanUp3 extension right now, and I clean regularly but it’s still pretty heavy.

Here is the Sketchup 2020 version of the model. Thank you!

Yes, cleanUp3 does purge as well.

the other workaround is to convert your manequin and other hi poly object such as cloth into vray proxy

image

the object wil be simplified, and you can adjust it by playing with “face in preview” parameter

the scene will be lighter, yet the clothed will rendered correctly. the main issue will be if you want to use sketchup image / screenshoot as part of your presentation, as the geometry will look ugly.

see this video for more explanation about vray proxy

the downlight works after i move it lower 10mm. the lighting object is intersecting with the lamp housing, so it dont work. if you want to make the downlight shine, paint the downlight housing with light emitting material just like the lamp bulb or chandelier.

Thanks so much for your help. I have a couple of question regard this subject

Did I really put the lighting cone intersect with the object? This is probably because somehow, somewhere along the line I accidentally move it inside the object, where I was intended to put the cone starting point to sit on the object surface.
And can emitting materials can replace the intensity of the spotlight? If yes, then should I use it instead of the spotlight/sphere light etc…? I only discovered about emissive material recently so I’m not too good at working with them.

Again, much appreciate for your help! :heart:

Maybe by a milimeter. its always safer to give distance betwen geometry and lighting object.

get yourself familiar with inference axis locking [ using arrow up, left or right ] while moving object, its one of most usefull tricks to make precise model in sketchup

i wont suggest it, as emissive material make much noise on hi intensity value; your render time will get longer significantly. combine lighting object as the real lighting and emissive material as the “source object” so far is the best option, unless you have irregular lighting source such as the neon box on your counter.

so; for the light bulb on the entrance display area; i would suggest using omni light scalled to match the lamp size, and use frosted glass material

ur welcome :smiley:

1 Like