Vray won't finish rendering

Hi everyone…!

Recently I’ve had some issues when rendering with Vray Next 4.2 for Skp 2020… Everything used to be fine, I could render ‘Very High Quality’ images, w2500 x h2000 for heavy scenes (sometiemes even using Vray Fur), using CUDA configuration… But, suddenly, last week, Vray decided not to finish rendering, sometimes when it´s about to finish, sometimes missing half render, sometimes not even starting to render… and even though, it says “FINISHED”

The thing is that this happens ONLY WHEN USING CUDA , rendering with CPU still works, but, of course, it takes much longer… I´ve even tried with models and scenes i’ve done before, but now it just won’t work…

I’ve got different messages from Vray Progress Window:

  • Checking CUDA driver version: Installed driver version is newer than the latest verified one!
  • CUDA error 702 : the device kernel took too long to execute
  • Failed to allocate 10240000 bytes, device 1, buffer default bufname

Hope someone can help me to solve this, it’s a very stressfull situation… :confused:

Have you tried asking on Chaos Group forum?

1 Like

Also check your Nvidia driver version.

1 Like

Hi @oalgarcia, currently experiencing the same issues. where u able to solve this? And how? thanks

1 Like

Hey, sorry for the late update to this:

Good news: I think I solved it
Bad news: I actually don’t know exactly what was the solution… :confused:

I did some research and tried a few things:

  • Update Nvidia Drivers
  • Uninstall the latest Windows updates (at least to the exact moment before the problem started)
  • Install the latest latest latest Vray version available (4.20.03 in my case)

This because, according to what I found, sometimes, Windows updates are not 100% compatible with Vray, so they need to launch a ‘new’ Vray version (like patches)

After that, I paused automatic Windows updates… (as an extra measure)

1 Like