Vray lights don't light up sometimes

lighting
render
vray
sketchuppro

#1

Hi,

I’m using Sketchup 2017 with Vray 3.6 for rendering.
Sometimes, random stuff happens with my model when it comes to lighting.

Day before yesterday, I put a rectangle light on a ceiling but it does not light up at all. I tried things like not making on the ceiling face directly but to no luck. I deleted it, made a new one - that worked for one render but in the next render and so on, it wont light up at all

Yesterday, I installed a 10 IES lights on a ceiling with exactly same properties. Surprisingly, only 3 of them lit up during the render. The other 7 wont light up at all. I analysed the different surfaces to see if there were any patterns but no luck again

I am totally confused and wasting a lot of time with this. If anyone can help solve my problem, I’d be really obliged.

TIA


#2

You have lost another 30 minutes! Upload a small file were this is happening and someone here can have a look.


#3

Hi Mike,
Here is the link to the file:
https://drive.google.com/open?id=1QKSnUCZwY6anf9ru10YWaOCX2Dr1vxjL

There are 10 small rectangle lights on the ceiling which are visible in the model as well as the attached screenshot. Only 3 of them are lit.

PS: I deleted most of the elements in the model to reduce the file size but it has not worked. (i think i sound very silly by doing that)


#4

deleting most elements has not much impact on the file size if they were components. All materials and components ever used in your model still reside in the component panel (And Material panel) in the ‘In Model’ collection (little house icon) . Purging (Window>Model Info>Statistics) reduced the model you uploaded from 133MB to 17MB…

As for the lights, I think tey are ‘Z-fighting’ with the other components. Place them a little lower/highr then the other. Lots of reversed faces in your model, too, you might wanna check in view>Face style>Monochrome setting, many render engines don’t processback faces (saves time…:wink:)


#5

yep concur with that. Definitely some Z fighting going on, single face light geometry in same Z plane so are occluded. if you move them 1 mm down for the downlight and 1mm up for the up lights that will fix, all that geometry is occupying the same space which basically causes what you saw! Ive done that in the screen shot below


#6

Awesome that worked.
Thanks @MikeWayzovski @bifterx


#7

You can also mark @bifterx’s answer as a solution


#8

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.