Vray glass not transparent


#1

Hey everyone I’m having a real hard time with Vray glass! It’s all turning out either black reflective or almost silver reflective, I’m trying to do hanging glass lights with see thru glass but nomatter what I do I can’t get it. Anybody have any advice? Thank you so much!!


#2

First thing to check is if you have any “reversed” faces?


#3

I’ve found that VRAY doesn’t like glass with no thickness…ie a single face. Glass in reality has thickness - maybe 1/4". If it’s curved glass you may need to use something like Fredo’s joint push/pull. Also, how many different glass textures have you tried? Have you successfully gotten your glass to render on a different surface? Can you try with a different glass vismat? I’ve never had a problem with VRAY 3.6’s built in vismat library. Please let us know if/what solution works for you. If nothing is working, try posting the .skp file.


#4

K awesome thanks for the quick replies!! I’m going to try the thickness and I’ll let you know!:grin:


#5

Ya it was the right way thanks!:blush:


#6

Thick Glass material takes longer time to be rendered. So if you have modeled the glass planes using single planes and with no thickness then you might need using let me call it “Fake Glass material” Using General template.
Here is an example:


#7

Hello everyone;

To not here:

I had the same problem and I’ve discovered that “using color texture as transparency” option also may cause the problem. Please try to open material editor and uncheck the box “Use color texture as transparency” under the title of “Diffuse”.

Have a nice day…


#8

Or set Refraction IOR to 1.0


#9

Roju , you are also right. If one is interested to use “Glass template” then may unlinke reflection/refraction. Then sets the values separately so that matches what is intended.
i.e. in depicted images I’ve set the reflection to 3 (That will increase the reflection to a higher value than the real world) while keeping the refraction to 1 that means no light bending.