[VRAY] All materials with weird reflection and shape HELP


#1

Hi guys,

Can you please have a look at the file I have uploaded and tell me why has my render became like this? Before you ask, I have not even opened asset editor since last render (which was good) hence I have not touched any settings, lights or textures. The same has happened to me earlier with the other, completely different file. I have rendered a few views with success then changed the point of view, clicked ‘render’ and this has happened… Can someone please help, I have lost a lot of work already, and of course I have tried resetting Sketchup a few times with both files, but it seems that this ‘setting’ has been saved for good. Oh, and I’ve checked all textures manually, none of them is reflective (except for the mirror), however all materials are for some reason reflective after rendering. I would very much appreciate any suggests, I am desperate to get the solution as this is not my hobby but my paid work and I will be presenting this to the customer soon! help :persevere:


#2

Try to reset V-ray setting and disable the IES lights, if you provide a link for your file, maybe someone here could help you.

Mousa Abu Doush


#3

You may also try reaching out on Chaos Group’s forum. They are much more likely to know what’s going on.


#4

Thank you for the answers. I don’t use IES lights, only spot, rectangle & sphere.

I’ve posted a thread on Chaos Group’s forum yesterday, but for some reason it’s not been published yet. Does it always take so long?

I have found a temporary solution, meaning I have copied the whole scene and moved it to the new file. It works but with bigger projects it’s almost impossible to copy all data - Sketchup cannot handle it and quits without saving :angry: I have also noticed that before I get a reflective render like this, it first doesn’t render at all - all I get is a black image (in both R and RT) and then when I try a few times it becomes reflective and ‘curvy’. I really don’t understand what is the problem, I have the latest SketchUp Pro 2017 with V-ray 3.0 and pretty good computer specs, I am really confused…


#5

Just because of this, i suspected that your model is very far from origin. If that’s true, move it closer to the origin and see if it helps your rendering.


#6

By origin you mean the axes? I’ve tried to move it closer but it seems that it has nothing to do with my render. I have Sketchup Pro installed on both Mac and Windows, I tried to open Windows file in Mac to see if it helps but unfortunately the same happens with the render. I’ve tried to disable all lights but this doesn’t help as well.

However, while rendering, the progress window shows ‘error loading plugin library rt_cuda.dll’ do you think it has something to do with it? And how can I fix that? thanks


#7

Well, definitely it has :slight_smile:
Interactive GPU rendering is not possible for AMD (OpenCL) at the moment. (But Progressive + GPU Acceleration should work for you). Check this for more info: https://docs.chaosgroup.com/display/VRAYSKETCHUP/Renderer
You need to have Nvidia (specifically CUDA type) GPU for interactive + GPU acceleration, that’s why you get that error probably.


So, you should be able to use Progressive with GPU acc. or not use GPU acc. at all for both. Test these accordingly and see if that works and let us know :wink:


#8

yes! it seems to be the source of my problem. I have turned off these features and I don’t get the cuda error anymore. The weird thing is that sometimes all functions allow me to render with success and another time it doesn’t render properly. I will test for a few more days to see if it really works without crashing my renders. thank you! :slight_smile:


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.