Strange reflection behaviors with new version of V-Ray

Hello! My materials have been exhibiting strange behaviors since update 6, mainly regarding glossy reflections: often the material shows no reflection at all, even though I have configured it correctly.
I have already tried a clean uninstall of both SketchUp and V-Ray, but the problem persisted. Below, I will send two scenes for you to see the difference, the first one rendered with V-Ray 5 and the other with the latest version:

V-RAY 5

V-RAY 6

See how materials with reflections behave differently, especially the black metal.
Here is its configuration.

Yes, that’s the point. Reflection layer is messed up in V-ray 6 for me :worried:

They improved the algorithms in vray 6 for reflections, but as you have a material made of fantasy properties , that might explain why it looks so different.
It’s also hard to know what else might cause such a big difference without seeing other settings - can you share the model?

I don’t use GPU as render engine, both images are processed in CPU. Only diference are the versions of V-Ray

This type of behavior is happening with all of my files that I was working on in the previous version.

I’ve identified that it’s some bug related to the fresnel of the reflection layer. When activated, the reflection doesn’t behave as it should; when deactivated and settings are changed, it shows reflection (the mirror has fresnel disabled, for example).

What material workflow do you use?

There definitely are bugs you can cause if you start mixing conflicting parameters - I’ve seen it a bunch of times on transparent materials and I’ve seen it when people have pulled materials from 3D warehouse models or ancient versions of v-ray.

If I make the same material as you, it shows as I would expect - not rough.

Can you share the file?

It’s happening with all materials, even a generic new one. If I just enable the reflection, it doesn’t behave as it should. Or as it was in previous versions for me.
Here’s the link to the file:

I’m not sure why, but your BRDF is set to WARD

It should be on Microfacet (GGX) , unless you set it otherwise.

When I create a new generic material, I get the GGX by default also.

1 Like

I like the effect of using the BRDF in WARD when I make metallic materials, but that’s not the point. The behavior is different in all materials, using any mode in the BRDF.
This file was made in V-Ray 5 and was working perfectly until I updated to 6.20.03 (the only one that works in SketchUp 2024).

I just did a test in a new file, brought the objects from the file that was having issues, and it seems to be working fine.
So far, what I’ve found is that the bug occurs in the fresnel reflection in projects created in previous versions of V-Ray when opened in version 6 or later.

I was about to say - I’m having some glitches generally. Trying to narrow it down.

Sorry I just noticed - is it the glass you have having issue with also?

Yes! Glass, metal, plastic, granite… any material that has fresnel activated in the reflection layer.

I understand now - now I can see that loads of objects are not showing their reflection in the reflection render element

1 Like

I found the actual problem (or item causing the bug)

creating some kind of weird volumetric bug in the model - moving further away from the objects caused the reflections to appear

The material on the ceiling has an ambient occlusion based dirt map on it - as soon as I cleared this it all looked correct.

before and after

Perhaps Vray 5 ignored it or it didn’t get upgraded correctly when it was moved into the V-ray 6 file.
The V-Ray dirt material was only introduced in Vray 6, so I suspect something has gone wrong with it.

2 Likes

My friend, I was about to give up and reinstall SketchUp 23 + V-Ray 5 again. You solved my problem, thank you very much!
I’ll test now without the Dirt on the ceiling material.

Update:
I removed the Dirt from the Diffuse slot of the ceiling material, but the same problem persisted. So, I reviewed the parameters of this problematic material and found an unusual option activated:
image
It was marked like this in the opacity layer, so I reset this setting, and even with Dirt activated, the entire scene returned to normal now. :star_struck:

2 Likes