VR viewer will not load simple models

I have 21.1.332 64-bit (still on eval which ends in 1 week), and trying to view a simple model using Oculus Quest 2 with the Sketchup Viewer for VR.
The viewer allows me to download models from the 3D Warehouse, and I can view the two models it has pre-loaded, so I do not believe there’s a problem with my installation.
I seem to have the same problem in the Trimble Connect web viewer as well - the models just report “failed to load” with no other explanation.
However, I’m able to load models I last published to Trimble Connect 2 weeks ago. I wonder if there was a silent update that bollixed everything? Nonetheless, even the two models that load in the Trimble Connect viewer will still NOT load in the VR viewer - I get “Failed to load - try saving in an earlier version of Sketchup.”
I would really like to see the VR working with one of my more recent models.
I’ve tried all of the following:

  1. Creating a really simple model and saving it as Sketchup 2020
  2. Publishing to Trimble Connect and loading from there in the VR viewer
  3. Saving as Sketchup 2019 and loading through Trimble Connect
  4. Loading directly from the filesystem locally, not going through Trimble Connect.

There’s an apartment building and dance center example in the VR viewer that I can navigate, and I can download other models from the 3D warehouse, but I cannot view any of mine. What am I missing?

As far as I can see, the VR viewing with Sketchup Pro is only supported with a viewer other than the Sketchup VR viewer for Oculus. All my searches for help on this point to various paid plugins. For my purposes I don’t need that, so my alternative is to export Datasmith and then drink from the firehose of learning Unreal Engine to create my VR walkthrough.
I really have no idea whether there is just some trick to getting the Oculus VR viewer to work (maybe I need to save as a 2018 or earlier version?), or it’s just demoware / vaporware that shows certain readymade models. But this gives me a viable alternative. I see that the release of the Oculus VR viewer was built and signed in December 2020, so perhaps there will be an update coming at some point that works. It certainly appears to be not fully functional.

Finally got this working:

  1. Save a copy as Sketchup 2018 (in the file format dropdown)
  2. Save to the default (C:) drive if, like me, you keep most of your documents on another disk drive