Viewer won't open 0.7gb model on 4th gen ipad pro?

Hi Folks, I have had a 3d model of a house we are going to build done by an architect in Sketchup and I am unable to get it to open on my 4th gen ipad pro. I have a full Sketchup pro subscription, as such I have been able to open the file on an 8 year old mac book both in Sketchup and in viewer. But despite adding the file via trimble connect and I’ve tried saving it on my ipad locally it never manages to open it. It downloads into viewer and sometimes the little thumbnail pic of the model updates to show our house but I am never able to get it to open!! It is driving me nuts as the 8year old laptop is so slow and I really want to view the model on the ipadpro to view the model is the only reason I bought the thing in the 1st place!! Can anyone help?

What happens if you try opening a smaller model on the iPad? Or an equally large but different model? Or open the same large model on the computer? I’m wondering if the model could be corrupted somehow, or if it’s just a matter of the viewer struggling with such large models in general.

Hi thanks for the reply to my post its appreciated. I’m able to open smaller models on the ipad no problem and I don’t have access to any other models of a similar or greater size to try. However I am able to open the model on my old macbook, both via viewer and in in sketch up. However when I try and open the model on my works laptop using sketchup online (I can’t install sketchup on due to admin restrictions) again it does not open!

So in summary I can open it but not on the brand new state of the art 4th gen ipad pro but only a nearly 10 year old mac book, but its painfully slow using it.

@colin, do you know if there is a file size limit for the viewer?

It sounds like the model may have been created with too much ‘detail’, possibly unneeded stuff. You may be able to weed through it slowly on your laptop and turn off some tags, not sure if that will help with the ipad though.
You could also ask the Architect for a simplified version.
.7gb is pretty big.

Going via Trimble Connect or 3D Warehouse may have limits. And the iPad app warns you when you are opening large files.

One thing to try would be to email the model to yourself. I just did a test where I sent a WeTransfer link to my iPhone, of a demanding 146 MB model. I downloaded that to the iPhone and then opened the model from inside the viewer app (using the cloud icon, and Files on Device option). I did get the complaint about the model being big, but it opened quickly, and worked well.

What Box says applies too, the more optimized the model is the easy it will be to handle.

Thanks I have the model saved onto the iPad directly and it uploads into Trimble connect no problem, its when I then try to open it with view on the iPad it does not work. I also have it saved as a file on my works laptop and again when I try to open with Sketchup online it wont work. I suppose what I’m confused about is that I have an ancient laptop which has significantly less computing power than my 4th gen iPad but it works on that and nothing else!! I really don’t want a reduced detail version of the model as I have paid for detail to try and help our family understand what the house is going to look like and I’d definitely prefer not having to buy another laptop having just bought the iPad pro!! Is there a way of sharing the file with someone at Sketchup to see if you have the same issues?

700MB sounds enormous even if the model contains every little detail. What happens if you open it in your laptop, open the Model Info>Statistics panel and click on the Purge Unused button a couple of times. My guess is that the file has lots and lots of unused stuff in the file, just slowing it down and putting the Viewer application in your Ipad to its knees.

1 Like

You don’t need to involve Trimble Connect. Use the Files app to put the model somewhere you know where to look, then in the viewer app touch the cloud icon, Files on Devices, then Browse from the bottom of that screen. Go to where you put to file, and directly load it.

Thanks Anssi, I’ll give that a try.

Hi Colin, tried that lots, saved it to files in my iPad and then opened directly in viewer it comes up with the message that its a big file and i should make sure the other apps are closed, i do that, it then says its loading for ages, then eventually the app just shuts down and the file never opens, no further error messages etc.

@Barry Do crash reports get sent in at times like that?

We get crash reports, but that’s a hang. On desktop on Mac, it’d be a spin dump. We are getting better crash reports, and if @wymcda PM’s me here, I could look. But I’m thinking what Box & Anssi commented: that model can probably be optimized.

Hi Anssi,

I did as you said and it reduced the file size to 300mb but still won’t open on iPad!

I don’t know anything about the mobile Viewer application. I just seem to remember that someone mentioned in this forum, when SketchUp version 2021 was released, that they had to save their models as older version (2020?) files to be able to view them with the mobile app. I don’t know if the app has been updated since.

I’ll give that a try. Thanks