SketchUp for iPad won't load imported .skp file

I have a brand new iPad (ninth gen model) and SketchUp goes black and restarts when I try to open a file created in the desktop version of Pro 2023. The file size is 115,490kb.

Can it open a smaller file? I understand the online versions of SketchUp have a 100 Mb file size limit. Not quite sure about this, and whether it applies to the iPad version.

Anssi, Yes the iPad can open the smaller starter files that come pre-loaded with SketchUp for iPad. I also thought the model size could be an issue, but 100mb is not really that big for a file.

100 Mb is a pretty large SketchUp file.

My iPad starts to flag in efficiency at around 20mb.

1 Like

100mb could be an entire building or single plant multiplied 1million times - the iPad would run out of memory before it opened

Thanks to all for comments on max file size. I tried importing and opening a smaller file size and it works fine. I’ll just need to watch file size and purge unused elements to keep the models smaller in the future.

That’s a good practice even if you aren’t going to open the files on your iPad.

It’s more than 3 times the largest model I have ever created.


I get away with bigger files on iPad. It could be that it’s the textures that are the problem. If those are huge they take up a lot of memory, even if they don’t take up much file space.

Thanks for the response. I’m used to a powerhouse desktop where I don’t have to worry about managing file sizes, but I’ll remember to pay more attention to this for models I want to show on the iPad.