View-toolbars-very heavy lag

I’m using sketchup 2017, Radeon Graphics Card 530.
there is a heavy lag whenver i go to view >toolbars, the blue wheel keeps on spinning for a long time before it opens and after i close it.
Please help.

How long is a long time?

Do you have a bunch of extensions with toolbars? In order to populate the list of toolbars SketchUp has to go through the list of your installed extensions and see which ones need to be included in the list and determine which ones need to show a tick mark for being displayed. When you close the Toolbars panel it has to update the file with your changes.

Is your Radeon driver up to date?
The Radeon 530 is classed as an “entry-level” card so you cannot expect quite stellar performance. However, SketchUp is also a very CPU-intensive single threaded application so your CPU performance also has a big impact.

If you are using multiple monitors, you might need to switch to one monitor to do what you need. Go go to your settings and set it up so you can only see one monitor. (Stop projecting to multiple monitors.) and then do whatever it is you want to do to get the toolset up and running and then go back up into multiple monitors.

I was just trying to get the full toolbar to show up as i was watching the educational videos on skethup.com about following and couldn’t get it open with multiple monitors. I stopped projecting to multiple screens, opened sketchup and got the toolbar up and running that i wanted and then projected to the multiple monitors. Worked. I wish i was able to go into view>toolbars with multiple screens open. Pretty lame. I tried a reinstall and the checkup and all \went fine but the problem and solution remain.

Sounds like you are running a Surface? (or something similar) With a low end CPU which is less than the minimum suggested hardware.
It is also possible that the toolbar dialog is opening off screen when you have multiple screens, that can be fixed.