View off axis when opening file/can't select anything

About every third time I open any sketchup file, the viewport comes in focused at some point to the bottom right of the axis origin. When I scroll/zoom the view is fixated on this point which is not my model. The view is in two-point perspective, which I never use. Also, I can’t select any points or bounding boxes. The tools select from the toolbar, but don’t engage or draw anything.

The only solution is to close the files (sometimes 3 or 4 times) and re-open and it will eventually focus on the model. This happens with all my files and not just one.

Not sure if this is a plug-in that is interfering or what. Quite annoying though…

Can you add an image, showing the problem and the desired result? Also, post a simple skp file for review.

I will try to take a screen recording of it. I am fairly certain it has something to do with another file being open behind the model I am working on. It seems like its using the axis origin of another model that is open in a window behind the active one. I just tried to do a recording and when I went to minimize the model window behind the problem window, it fixed it.