Vector printing breaks Sketchup

I am a woodworker who uses Sketchup to design my projects and regularly print parts at full scale to use as templates directly from Sketchup. I am not an expert at Sketchup by any means, but have been a user since 2020 (started with Sketchup Make 2017), and I have done this many times with no real issues.

All of the sudden (this week) the vector printing option in the print menu is breaking Sketchup. It will distort the model and make navigation (zoom, pan, orbit) near impossible to use. I will have to close and reopen project to reset. It does not seem to be unique to a specific file, as I have tried with multiple models. I tend to use the vector option to get thicker, crisper lines in my printouts and printed the exact same way last week with no problems. I’m not sure if Sketchup updated itself and it is a new bug, but I have not done any manual updates to Sketchup and know that macOS has not been updated. I have narrowed it down to the vector printing option causing the issue.

Here is an image I was able to capture of my model when the issue happens.

Computer Specs:
MacBook Pro (16-inch, 2019) running macOS 12.7.2
Processor 2.4 GHz 8-Core Intel Core i9
Memory 64 GB 2667 MHz DDR4
Graphics AMD Radeon Pro 5500M 8 GB

Sketchup Pro 2023
Version 23.1.341

Printer: Epson ET-4850

*Edited to add screenshot

SketchUp doesn’t update itself and there has been no recent update. Share your SketchUP model file so we can see what you are starting from.

Since you haven’t mentioned LayOut, I presume you aren’t using it. Is that correct?

As I mentioned, it does not seem to be model specific. I’ve tried with multiple models and ran into the same issue.

Good to know Sketchup does not update itself.

I do use LayOut, but mostly for sending clients designs. I don’t use it for printing out templates for woodworking as I learned how to do that in Sketchup originally with Sketchup Make 2017 and had no problems in Sketchup 2023 until now. LayOut is relatively new to me since I’ve only had Pro license for about a year. I know others use it to print full scale, but seemed like a lot of extra steps to take when I was able to just print directly from Sketchup.

Also, I don’t know if I made it clear, but I can print without the Vector Printing option selected with no issue.

Printing to scale was removed from SketchUp 2023, though. It’s much easier to set up in LayOut anyway. I’ll look at your file and see if there’s anything that might be causing it.

I appreciate it.

I have read in other post, while researching this issue, that print to scale was removed in SketchUp 2023, but I’m a little confused about that. I’m still able to set print scale to 1" in Drawing = 1" in Model in the Document Setup. Which is essentially how I’ve always printed to scale. Sorry for any blatant ignorance.

Document Setup is in LayOut, though.

I’m about to start with a student but I’ll get back to this ASAP.

No rush, but I do want to share I also have Document Setup in SketchUp.


Print options from SketchUp are different between Windows and PC but I think you end up in the same place.

I noticed that in your Scene 1 you haven’t got the camera set to Parallel Projection or the standard Front view. Changing those settings and updating the scene should help. They do here.

Here’s the PDF I exported after correcting the scene setup.
PHD_Nightstand_v1_working.pdf (2.6 KB)
And if set to poster print in Adobe Reader it will require 4 sheets to print just as your second screenshot shows.

Set up in LayOut on 11x17 paper and exported to PDF results in this file.
PHD Nightstand.pdf (2.7 KB)
Which only requires two sheets of letter sized paper to print.

By the way, you could improve the efficiency of your model. It would be a good idea not to string your model out the more than 400 feet as ou have it.