Problems with printing setup in SU 2016

I’ve recently downloaded Sketchup 2016 so I’m in the 30 day pro trial stage. I’ve been trying to print a model but I’m having some strange behavior happening within Sketchup.

When selecting print from the menu after I set up my page and document settings, the print dialogue goes blank and I’m unable to select any options and my file menu is mostly grayed out:

I’m on an iMac using El Capitan version 10.11.3

Any help would be much appreciated!



Try turning off Hardware Acceleration in Preferences>OpenGL. You’ll find Preferences in the SketchUp menu to the left of File.

Apple’s print menu is attached to the window and is system-wide. Can you print from any other application?

Thanks for responding. Here is the latest:

Printing in any other app doesn’t cause a problem just Sketchup. I’ve also turned off Hardware Acceleration and my print dialog doesn’t appear blank anymore but I’m still have issues when trying to print. Sketchup has been freezing at the print window. I try to choose print quality, vector or line weight but Sketchup freezes.

t’ve uninstalled Sketchup 2016, reinstalled again twice but I’m still having issues with anything that has to do with printing. Sketchup keeps freezes and I have to force quit and try again. I downloaded SketchUp Make 2016 this morning but still same problems.

I can’t even open Sketchup 2015 to try because it’s telling me my “pro trial” has expired and don’t have an option to open it in the free Make version. I’ve just been having non stop issues with the software.

I’ve tried using my licensed Google Sketchup Pro 7 I purchased years ago. But the print dialogue screen is blank - among its other problems…

Again, if you can get the print window, bottom left should be “PDF”. See if you can click on that pulldown, then “Open PDF in Preview”.

And if you’re freezing, Apple has SpinDump: type Command-Option-Escape, and Force Quit SketchUp. That should generate a spin dump. Send that to me in a private message, and it should give us some clues about what’s happening. Specific model of printer and the print driver you using would be helpful, too. Thanks.

try resetting the print settings of the recent page attributes by pressing/holding the option key while clicking on “Settings: Page Attributes”:

Then choose something like “Reset to original Defaults” from the dropdown list.

I’ve tried resetting the print settings but I’m unable to change anything. I click on it and no options pop up.

I am able to click on the PDF dropdown menu and open pdf in preview if I can get to that menu before it freezes. I’m afraid I’m not familiar with SpinDump. After I force quit Sketchup, how do I find the spin dump to send to you?

If it didn’t pop up in a window, it’s stored in /Library/Logs/DiagnosticReports/ and should start with “SketchUp” and end with .diag

And you can then print properly in Preview?

clicking is not sufficient, pressing/holding the option key required.

Sorry, I meant to say I did press/held the option key but no luck.

Preview seems to crash when I try to print so I have to open it again, to get it to print after a second try.

I checked my /Library/Logs/DiagnosticReports/ but didn’t see anything referencing “Sketchup”.

So far today, I’ve been able to print using ‘open PDF in Preview’ and also using the print screen directly in Sketchup; however, the minute I try to print to vector (checking the box for Vector) Sketchup freezes and then my screen goes wonky (like the included screen grab). Then I have to force quit.

how far is the model from origin?

and/or can you post the skp?


Yea, you wont get vector going that route (print to pdf vector takes special handling). Do you have Pro? Can you print from LayOut? In LayOut, if you render in vector or hybrid, you will get vector (exporting to pdf).

To get spindump to work, you have to beachball (google the acronym SBBOD), then kill SketchUp via cmd-opt-esc. If you’re not getting SBBOD, you wont get a spindump.

are you absolutely sure that “SketchUp > Preferences > OpenGL > Use Hardware Acceleration” is disabled?
did you have restarted SketchUp after doing that?