SketchUp 2015 crashing when I try to print


#1

Does anyone know an alternative to Sketchup, cheap to free, that will read Sketchup files?

Sketchup has been crashing when I try to print. It works if I persist, but it is really irritating if I have not saved. Save before printing. Also, has print gotten coarser? Did it change from vector to raster or something? Even on high definition, the print is full of pixelation.

The past few days I have intermittently not been able to start Sketchup. It (or maybe NVIDIA) claims my hardware won’t support it.

I have been running the free SU 2015, 64 bit version. I am installing the 32 bit version now to see if that helps. I am on a Dell Latitude E6430 laptop using Windows 7 Professional, SP1. It has 8G ram, 64 bit OS. Video is handled by an NVIDIA NVS 5200M.

Thanks


Anyone know of a good SketchUp alternative?
#2

You might try the SketchUp 2014 Make version.

It is OK to keep more than 1 version installed side by side. (I have 4 versions installed because I do testing.) You’ll just need to back save to v14 format.

You might try disabling Hardware Acceleration in Preferences > OpenGL.

Close and restart SketchUp after making settings changes. (Many of the settings only get written into the registry when SketchUp shuts down normally.)

This also may include the Print settings. So yes save your model before printing, then close and restart SketchUp after a successful print task, so that the print settings under the “SketchUp 2015” registry key get updated.


#3

Thank you very much, Dan. Your suggestions sound well thought out, I will try them.

Steve


#4

A lot of free CAD programs such as IMSI Doublecad will now read SketchUp files but you shouldn’t need to.

I do agree that printing in Sk2015 is a bit buggy. Dan’s suggestion to disable hardware acceleration is a good one. You might find as I did that switching it off and then back on surprisingly solves the issue. Also try unchecking ‘use model extents’. Again this solved a print bug that I previously had.

By the way is it printing to an actual printer that is the issue or to PDF? If it is the printer itself then double check the hardware settings and also you could try printing to PDF first and then printing it out.

More likely however it is your SketchUp print settings. In your print settings, set print quality to ‘Ultra High Definition’ for raster prints, or check ‘Use High Accuracy HLR’ for vector. The latter is the highest quality however textures and shadows won’t print as these are raster based. In addition within ‘Properties’ select ‘High Quality Print’.and under ‘Advanced’ you can also set the DPI (I use 1200). These settings should achieve a very high quality output.


Anyone know of a good SketchUp alternative?
#5

Thank you Kenny, details I was missing. I am printing to a printer, same one as for many years.

Steve


#6

nVIDIA describes their NVS line of GPUs as aimed at multi-display 2D business graphics.

The minimum SketchUp Hardware and Software Requirements state:
3D class Video Card with 512 MB of memory or higher.
Please ensure that the video card driver supports OpenGL version 2.0 or higher and up to date.

NVS 5200M Tech Specs indicate it supports OpenGL 2.1
Make sure your graphics driver is up to date.
See … How can I update my computer’s graphics driver? — SketchUp Help
Of course, NVS GPUs may lack other necessary ‘technology’ for 3D … who knows?


Then there’s another thing that might be causing the problem.
Your NVS 5200M incorporates NVIDIA® Optimus™ technology.

The product description says…
“nVIDIA NVS with Optimus technology enables outstanding graphics performance and longer battery life by automatically switching on and off the GPU so that it runs only when needed.”

It seems to me that setting up print options is more or less an idle process in terms of GPU usage.
Perhaps the Optimus feature is shutting down the NVS GPU and handing the load back to the on-board chip.

Does your nVIDIA NVS control panel offer an option akin to the what @Anssi describes in this topic?
Therein, notice you can assign certain applications to only use the high performance GPU.


#7

More details: this computer. OS and printer have worked fine with Sketchup for about two years. I think the issue lies with Sketchup 2015. Also, the NVIDIA problem comes and goes. Today Sketchup almost behaved itself–printing crashed it, but the print completed.

Steve


#8

Are you submitting the crashes so we can see what’s crashing it?


#9

I confess to not reading the bug splat form at first and just sending them in. I have switched to actually including my email :slight_smile:

Steve


#10

I’m not seeing them; what version SketchUp, Mac or PC?


#11

Windows 7. My email starts with sos


#12

Found crashes. Found bug. Original bug was printing with Sketchy Edges in some situations, but that doesn’t appear to be complete. I researching some more…


#13

I hope that is a typo… graphics requirements for over half a terrabyte of memory? :wink:

Beverly Howard


#14

Yep … 512MB not GB


#15

Because this is the Technical Problems category, renamed topic to state the actual issue, as:
SketchUp 2015 crashing when I try to print

was:
Anyone know of a good Sketchup alternative?

Created a new topic of the former title, in the Corner Bar category, viz:
Anyone know of a good Sketchup alternative?