Vector fills are rasterised when printing


#1

When printing a vector drawing from Layout, I have a major issue - wherever there is a fill box, it becomes rasterised AND it rasterises anything within or touching its bounding box - text, lines, other fill. It doesn’t happen on screen and it doesn’t happen if I export a pdf and view that. If I print that pdf, the same rasterisation happens. As a rule I stick to high quality settings throughout. I’m printing to two laser printers, both with Adobe Postscript, one b&w, one colour, it happens with both.

As a workaround, I have discovered if I open the pdf in Adobe Reader and print from that, it doesn’t happen, but that’s adding more stages to what should be a simple process. I’ve had a similar issue in Swift Publisher, unresolved. All suggestions welcome as this is very frustrating!

SketchUp Pro 2016, 2016 27" iMac El Capitan, AMD Radeon R9 M395


#2

Do I understand right: When you export a PDF from LayOut and view it in Adobe Viewer everything looks as it should?

What do you mean by rasterized? Irregular blocky black outlines? That is a bug that seems to haunt Mac users with certain AMD graphics cards. The developers are looking for a fix, but it might be a Radeon driver problem (as your seeing the same in another application suggests). This is discussed at length in Black areas showing up in 2017 Layout viewport.

Anssi


#3

Yes, but a Layout pdf viewed in Apple Preview or a browser looks fine as well. It will only print correctly from Adobe Reader, not directly from Layout or pasted into other dtp programs.

By rasterisation, I mean things become very slightly blurred - I don’t have the black areas issue (which is why I’m holding back on 2017 for now). I tried a test file in Layout 2017 however and it has the same issue.

I have the same issue with my Mac Mini with an NVIDIA GeForce 320M card as well. These are A3 architectural drawings. There is a noticeable difference in line weight and colour where the issue occurs.

It seems to me that Apple’s print engine is somehow responsible but I’m not quite sure how that works - does it convert a print command to a pdf to send to the printer? If so presumably Adobe Reader overrides that, hence the difference. But surely someone else has this issue?!


#4

if your using the AdobePS print driver then the Apple print drivers have no effect…

if you search for mac AdobePS driver issues you find quite a few…

can you use an Apple supplied driver or CUPS for your printer?

if SU is producing PDF-X files, then that could be the issue as it provide 72dpi transparency masks which would need to be increased…

john


#5

You might be onto something with the 72dpi - that may well be how it is printing to produce the areas of lower quality - to do that surely it must be converting the vector parts to raster, as vector is scaleable? I have a basic grasp of pre-press but pdf’s can be a black art. For the colour laser, I can switch to a generic driver - I’ll try that and see if there is a difference.

When I print directly from Layout, what happens when I click on ‘Print’? Does Layout generate a pdf to print from? If so, presumably it uses part of Preview to do so, which then creates the issue. That Apple pdf must have some further processing if printed from Adobe Reader to overcome the issue. Just thinking aloud here … Is this an issue on the Windows version?


#6

the mac version uses the built in QuartzPDF functionality and the Windows version uses PDFlib 9.0.2…

historically, Adobe ‘fails’ to recognise some Quartz features and some [different] PDFlib 9.0.2 features…

supplying a Quartz PDF-X was a workaround for this shortfall in the past, but the 72dpi setting is an issue with large format or high res output…

/System/Library/Filters/Create Generic PDFX-3 Document.qfilter

			<key>FlattenTransparencyResolution</key>
			<array>
				<real>72</real>
				<real>72</real>
			</array>

the quartz filter can be manually edited to 300 or 600, but I don’t know if SU/LO apply this filter or hardcode their own settings…

@Barry might know?

john


#7

Interesting, which prompted me to search around - eventually found this and ‘Miller’s’ comments make for interesting reading.

I did try copying and editing the pdf-x filter to 300dpi, but it didn’t work - it did however give me a pdf where I could see the issue before printing, as attached. The blur is from the edge of a bounding box of irregular shaped fill further up the drawing.

https://www.prepressure.com/pdf/basics/pdfx-3


#8

so, it does seem to be a transparency filter issue then…

I had also looked at that link in the past…

the other thing that may be ‘throwing’ the AdobePS driver is how QuartzPDF versions it’s output…

it uses the ‘lowest’ version needed to view the content and if read as ‘strict’ by the print driver then some features may be downgraded or lost…

check file info ‘version’ for both a raw export and an Adobe Reader save of that file…

I suspect they will be different…

john


#9

You are correct - Preview is 1.4, Adobe Reader save 1.6
.


#10

I haven’t tested it, but I suggested on another thread that adding a ‘higher version’ item to your LO template should produce a higher version number and that may ‘trick’ your print driver into printing correctly…

I don’t have a use, so didn’t pursue it further myself…

if you check the 1.6 PDF specs there’s probably something easy to incorporate…

john


#11

The 1.6 PDF Specification is 1200+ pages long! I looked at the ‘what’s new’ section, but most of it made no sense to me and nothing jumped out as a specific item I could incorporate. Any suggestions please?


#12

I have historical knowledge but nothing recently as I haven’t worked on LayOut in a while. Nice Quartz PDF-X, John.

There is this thread: Export Layout to pdf version 1.7 on Mac but we all agree, this is NOT a good thing to do just to say you’re 1.6 compatible, as @john_drivenupthewall mentions.