V-Ray license stopped working

I had Sketchup Pro. Started a 30-day trial of V-ray. Liked it. Decided to upgrade to Sketchup Studio as it included V-ray. Now V-ray trial has ended, and I can’t seem to re-liscense it. I’ve tried reinstalling it. same results. Do I need to completely remove it first? How do I do so if need be? Will all of my V-ray assets still be included in my projects after this process? HELP. I’m working on a big job!

Did you receive the vray license after buying sketchup studio license?

It’s included with the Sketchup Studio package as a download. Buying Sketchup Studio gives you a web page with 16 downloads. I have access to these, and everything installs just fine. But it’s all disabled. It says no license is available when I try to use it… The license server doesn’t show any licenses available after installation.

You may want to remove that image or obscure your email address.

thanks

1 Like

I’m getting absolutely nowhere. No response from Trimble, no response from Chaos. No chat, no phone support. I feel like I’ll need to fly to their offices to talk to a person.

I’m absolutely stuck, with work deadlines looming, and I feel completely helpless. I just need some tech support. For what I paid, I’m disgusted at this lack of response.

Not that it helps, but if I get my timezones right it is still late Sunday night where they are and the don’t run 24/7 support, so you may get an answer in the morning.

Before getting a plane, sign out in the SketchUp App via the [menu] Help > signout email….
Exit SketchUp

open a browser on the machine where you had the trial, type ‘localhost:30304’ in the addressbar and hit enter.

Then sign out in the middle.

Then sign in, this time, be sure to use the Trimble sign in option.

Check to see if it starts to recognize the license.
Open SketchUp and sign back in to see if it works.

They responded with a canned email from a support tech in Romania. It just linked me back to the standard support page where I get nothing after clicking sub mit. No support ticket number in response…nothing at all.

No, It says I have no Active products. Same as before.

when you reach Vray 's page to authentify and activate your licence, you need to log in using trimble connect, not the account you made earlier to try the 30 days trial.

the studio licence is directly linked to your trimble account.

Capture d’écran 2023-12-11 à 09.07.53
check here, extension / vray / help / license / license server.

if it’ opens your 30 day trial account, then off course you don’t have access to the studio license. You’ll need to… I’d say release then activate license again and this time choose “continue with trimble”

1 Like

Tried that no luck.

What does it say when you go to mychaos.com and hit the ‘license’ tab?
You might not see active products, but it should display something overthere.

Sometimes, reassinging the Studio license itself triggers the process.

This is done if you go to myaccount.trimble.com.
In the Members section, revoke access for the email you are using, then reassign the product.

Now, sign out in the SketchUp app again and exit.

Use the link in the received email to trigger the assignment.

I have been in the same limbo for months. What helps for some seems to be revoking and reinstating the license. It seems to be the standard action the support does. Hasn’t helped me, though.

Thanks everyone for your assistance! You’re all good people and should be commended for your efforts to help others. I appreciate you.

So here’s an update. I purchased an additional stand-alone license ($466) so that I could get my work done. I am back up and running with the standalone “Solo” license. Not long after, I finally got a response from Trimble Support after hitting every contact I could find there and sending about a dozen emails. They revoked my Studio license and gave me a new one, along with the following information.

Thanks for reaching out to SketchUp Support!

I understand your frustration right now and urgency, however as you were unable to contact us directly we were not aware of your situation.

As SketchUp Studio comes with a V-Ray license already, you will need to contact V-Ray for a refund for the license you purchased separately. After you have been refunded and if you are still unable to activate a SketchUp for V-Ray license, please follow the steps below. There is no need to downgrade your plan to Pro.

I did some work on my end. Please follow these instructions to sign back in:

1.Sign out of the Chaos license server at http://localhost:30304 (by clicking on “online licensing” at the top)

  1. Sign into the Chaos Licensing Server at Chaos

  2. Sign out of the SketchUp desktop application

  3. Close SketchUp completely

  4. If you are on Windows: Click on the Windows search bar and type “Change V-Ray license settings” and press enter. In the Chaos license settings window make sure that “Primary license server” is set to 127.0.0.1 and port 30304. Click Ok to Save the configuration.

  5. Delete the SketchUp login_session.dat file to completely clear your login information:

On Windows: In File Explorer, go to Windows (C:) > Users > your user name > AppData > Roaming > SketchUp 2023 > SketchUp

On Mac: Go to your desktop, you should see “Finder” and “Go” in the top left menu bar. Click on “Go”, then hold the Option key and “Library” should appear in the list. Click “Library”. Navigate to Application Support > SketchUp 2023

  1. Sign back in SketchUp

I’m going to finish my work and try this once complete. I’ll post a new update after the process is complete.