V.15 problems

I don’t even know where to begin. Several years ago, I installed Sketchup 15. I had been using it to draw small, two dimensional items, and then exporting a DXF to another program to create a drawing that could be printed as a PDF. I recently had to do away with my old Win7 computer, and reinstalled v.15 on my new Win10 computer. Now, I don’t have the ability to export to DXF anymore.

I know everyone is going to tell me to upgrade to the NEW and IMPROVED version, but let me state emphatically, that is NOT an option for me, for several reasons, not the least of which is, I neither want to have to learn a new version, nor am I willing to pay the exorbitant price being charged.

So, having said that, I’m also sure someone out there knows what I can do to be able to export a valid DXF file from Version 15. What do I have to do to accomplish that?

Are you referring to SketchUp 2015? Is there a chance you used to have a trial and it just expired? Are you open to possibly using different software to get the same job done?

As far as I know (not a ton), exporting a dxf is purely a Pro feature and that you have to pay for.

1 Like

See if this works …


The main reason TO upgrade is that v2016 was the first to officially support and be tested to work with Windows 10.
https://help.sketchup.com/en/sketchup/sketchup-hardware-and-software-requirements

There is still is SketchUp 2017 Make available for download.
You can install separate version side-by-side on the same machine.
They install into different folders and have separate shortcut icons.
If you’ve never installed v2017 on your new Win10 machine, it will run as Pro for 30 days and allow DWG/DXF import and export.

Thanks, these are some good answers. I’m not entirely sure why, or how, but I had some sort of plug in or aftermarket add on that enabled exporting DXF and STL from Sketchup. I do know that it wasn’t a “trial” or anything, it was just regular plain old Sketchup, and I was able to export from it. I also had some sort of “unfolding” plug in that also doesn’t seem to be there now. It would enable me to take a 3D object drawn, and click on each face, one at a time, and it would “unfold” that face, putting it on the same plane as the previous face. That’s missing now too.

I’m still not sure what to do here, or how to go about doing it. I had gotten so used to using it, that I simply stopped paying attention to what I had done with it.

If you have experience with CAD programs you can install DoubleCAD XT (free) that can open SKP files and save out as DWG/DXF or print to PDF.

https://www.turbocad.com/content/doublecad-xt-v5

It’s not the greatest program but it does do what it claims to do in regards to opening SketchUp files and saving back to DWG/DXF or vice-versa.

This post was flagged by the community and is temporarily hidden.

You don’t need pro to use plugins and extensions.

The one that you mention that unfolded things would most likely have been called Flattery by Pumpkin Pirate.

My bad. I thought only Pro allowed extensions. Just trying to help!

1 Like

That’s ok, just making a correction.

Thanks. I found an online converter that claimed to convert STL to DXF, but it doesn’t work in the CAD program I have. Instead of giving me an outline of the part, which is what I need, I get the outline, plus hundreds of lines (Think “spider web”) inside the shape that cannot be removed. I’ve tried everything, and even wrote the developer of the CAD program, and he doesn’t know what to do either. So if I can convert my drawings (they’re all flat, 2D polygons) to plain outlines, and then edit them, then I should be okay.

1 Like

I’m not sure that’s the one, but it may have been. I just don’t remember. Sometimes, I feel that if my memory got any worse, I could plan my own surprise party! I wish I could find another decent unfolder for the version I have. Thanks!

Yeah sometimes those online converters promise the moon :wink: What if you went straight from SU to DXF and skipped STL all together? This was my idea in pointing to DoubleCAD. Best of luck Tess.

Read this discussion and you may find the names of the plugins you have installed before:

Thanks, that might well come in handy!

I’ve also downloaded and installed the CAD program that was suggested to me earlier, and I’m in the middle of preparing something basic to test on it.

Thanks for all the assistance! This issue will be beaten with all your great help!

It’s simple. You had extensions installed. Find them and reinstall them.

You can install extensions from within SketchUp, from SketchUp’s Extension Warehouse.

A change from the older SketchUp versions, is that SketchUp now has a dedicated full sized Extension Manager dialog window. (No more tiny Extensions panel stuffed into the Preferences dialog.)

Or, you can download extension archive files (RBZ) and install them manually.
There is a “Install Extension” button on the bottom of the Preferences > Extensions panel (older versions <2017), or bottom of the Extension Manager window (newer versions 2017+.)

There are quite a few. I linked a free one above.

This is a free community plugin that is offered on the SketchUp Team store in the EW …
http://extensions.sketchup.com/en/content/sketchup-stl

There have been several of those …


There are also many free extension over at SketchUcation PluginStore.
They have SketchUcation Tools that is a manager that can install plugins and extensions for you.

I seem to remember some unwrap and DXF extensions over there as well.

DXF

Unfold, Unwrap, etc.

Thank you for such an excellent, informative, and detailed reply! I managed to get the DXF export plugin working, but neither of the unfold/flatten plugins will install. And I am not sure why, but I can’t seem to find any others.

In any case, thank you for the information! Very much appreciated!!

At the risk of sounding needy, whiny, and entitled (Believe me, I am none of the above!) The way the original plugin worked was, you clicked on one face in the item, and then opened the plugin in the Tools menu, and there was the word “Unfold” in the dropdown list. Click on it, and then click on the next face, and every successive face, and they all unfolded into the same plane as the first face you clicked.

The only reason I posted the description, is that neither of the two listed plugins operate the same way.

Again, thank you for the help!!

I seem to also remember Jim Foltz maybe having an unfold plugin.
I’m not sure if he distributes his old plugins anymore.

You can rename zip files to .rbz and manually install them.

However, it was written long ago when SketchUp used Ruby 1.8.
All current versions since 2014 use Ruby 2.x so it may encounter load errors.

@jim_foltz (ping)

Yes, thank you. I tried it and could not find any files to download. I’m not going to give up, because I had it once, so it must be there somewhere. Even if I have to fire up the old Win7 computer, it’s there on the drive somewhere.

In folder …
C:\Users\<username>\AppData\Roaming\SketchUp\SketchUp 2015\SketchUp\Plugins
… look for a file named something like …
"unfold.rb" or "jf_unfold.rb"
Also check to see if there might be a folder to go along with it. It’d be the same name but without the ".rb" file extension.

Select the file, and it’s companion folder (if present) right click the selection and choose “Send to compressed folder” (or similar). Then select the resultant zip file and rename it’s file extension from ".zip" to ".rbz". Move it to a thumbdrive, and eject the thumbdrive.

Then install the RBZ to the new Win10 computer as explained elsewhere (from the “Install Extension” button inside SketchUp.)


EDIT: Topic muted.