Using shift key to enter dimensions for a rectangle creates a crash


#1

I want to enter dimensions for a rectangle. To enter the dimensions I use a german QWERTZ keyboard. To separate the two different numbers I should use a semikolon. To get the semikolon (above the comma on the german keyboard) I must press the shift key. But every time (100%) I press the shift key sketchupmake 2017 crashes. I tried it with the german and the english version.
Perhaps somebody can help.

Windows 10 64bit
Firefox 51
Sketchupmake2016 is still working


#2

Why? To separate X and Y length inputs, SketchUp needs a standard comma ( , ) instead of a semicolon ( ; ).


#3

In some locales the , is the decimal separator - rather than the normal .
So then the , cannot be used to separate values in the VCB - a ; must be used

So the 'normal’
1.2,3.4
must become
1,2;3,4

Unfortunately some locale’s keyboards require shift-operations to get to a ; character, which can then break things…

I’m sure Trimble are working on the glitch as I type…


#4

Thanks TIG, that’s the reason.
And yes, in Germany the comma is the decimal separator. And because of that the X and Y numbers must be separated by a smicolon. And on a German keyboard the semicolon is on the key right to the “M” above the comma. And for that it’s neccessary to use the shift key. And the help videos of sketchup show exactly this even for the english version. And it worked with the 2016 version.


#5

And of course pressing the shift key should never splat !
And indeed, US/GB users need to press shift when typing feet and inches thus 1’6" since in the US keyboard the ’ is shifted-2 and in the UK keyboard " is shift-two [the two keys are swapped for some weird reason !]

Ping @ChrisFullmer


#6

Huh? On my US keyboard, single-quote is an unshifted key (next to enter) and double-quote is shifted single-quote. Shift-2 is @


#7

You are of course right ! [At least with your MAC version ?]
I use a a PC UK keyboard and occasionally fall foul of computer sharing with US…
When our key presses are messed up…

But whatever keys they are, it still needs a ‘shift’ to get to one of them on either keyboard type!

I also think that the shift-3 for UK £ is actually # on US ?
What are on the key to the right of ./" in US - in UK it’s #/~ !

Here’s a GB keyboard, with shifts.


#8

Well that’s not good! No I’ve never heard of this shift key crash. Thomari, when it crashes, have you seen any “bugsplat” screens, asking you to send in your crash information?


#9

Oh I see that you did submit some bugsplat reports. I’ll see if I can get an engineer to look into why its crashing there for you.


#10

I just wantet to answer, but I have seen you found my reports. If you need some additional information don’t hesitate to ask for.


#11

And I have a German keyboard like described before, not a UK or US one and it’s Windows.

The error appears if I press the left mouse button to draw a rectangle and release it. Then I want to enter the dimensions. I can enter numbers, but sketchup crashes if I press the shift key before or after a number .


#12

Can you recreate this crash using other tools? How about these:

Rotated Rectangle tool
Scale Tool - scale from a corner grip, and press shift. Then input different scale values after the scaling is done - like 3,2;1,1:0,9 or something like that.

Do either of those also cause a crash?


#13

OK, there seams to be a bigger problem.

The rotate rectangle work
the Scale tool creates a crash just pressing the tool button
the save and save as create a crash too, after I entered the the name for the file and clicked the save button.

Perhaps it’s a installation problem. Because I have had installed the pro version for just a few hours. Then I uninstalled this and installed the make version. And there is already the 2016 Make version installed. Perhaps there some entries were left in the registry or in the filesystem.


#14

@Thomari - We do have some known crashes with ATI graphics cards. Can you try the troubleshooting steps in the following article and let us know if that fixes the crashing? http://help.sketchup.com/en/article/3000345


#15

Thank you Stacy,
I uninstalled all 2017 Files and registry entries in ProgrammData, Programms, user Appdata Roaming and some places in the registry. Then I installed Sketchup again. The error came again.

Then I installed your recommended workaround and it works. So I think it’s definitly the ATI-Problem. I read the workaround earlier at the forum website, but I couldn’t imagine, that it could be connected to the problem with the shift key, even the hint is in red color and highlighted.

Perhaps It would be a good idea to give some examples of errors at this place, which can be caused by the ATI problem. This could possibly save you some time helping users like me.

Thanks again


#16

Great to hear these steps worked. I will provide your feedback about the article. Thanks!


#17

Hello Thomari…Good to hear you recieved help and all is working.

We also needed the semicolon in Denmark… but…
my solution was, to install “Windows Ultimate, English version”.
Now my comma in the numeric pad works fine, as separation between values.

Other benefits is,that Window shortcuts also follow the english keyboard…
and I can use information directly from examples on the internet…
And…
I train my english…!


#18

Hi Jakob Hovman,
I think the english version of Windows wouldn’t have solved the problem. Because the most important differences are the (silly) german umlauts (the vowels with the two dots obove), which cause a different keyboard layout. So a english keybord (physically and in Windows) would have solved the problem – perhaps, but the better solution is the workaround because of the problems with the ATI graphics card respecticely the drivers.