Separating dimensions with "." instead of ";"

Hi,

When entering coordinates to draw a square, Sketchup has different effects depending on whether you are using inches or centimeters.

If the metric units are inches, you can enter value 2.5,2.5 or 2.5; 2.5
If we draw in centimeters, we can only enter value 2,5; 2,5 and there is no alternative here.

A request to add the option to use the version with a period “.” as a separating version. I know it sounds weird, but I use the 3D Connecxion mouse more and more and have a virtual keyboard at my disposal. (the virtual keyboard does not have the semicolon “;”)

Of course, I can reach for the physical keyboard, but it distracts me from drawing and instead of focusing on designing, I focus on putting my hands back and forth.

Or maybe there is already a way to assign this option in Sketchup?

I will be grateful for a hint or adding a function

Regards,
Michał

Is this related to language? I am in the UK which means I use metric but a full stop as a decimal point. It is standard practice in the rest of Europe to use a comma as a decimal point, so presumably it works differently for them.

In fact, in Europe there are differences in the use of periods and commas depending on the country.

Nevertheless, I would like to ask for help, because I would like to actively use the virtual keyboard. I assume that people who use the reverse format in Europe would also want to be able to choose the way in which dimensions are entered.

If this is a big problem or a meaningless option, maybe someone will show me how to do it in Ruby console?

What does the ‘Measurement’s’ box show you? Aren’t they displayed the same way in the input field?
There should’t be any difference.

Yes it is the same.

Therefore there is a problem to enter both dimensions (height and width) without a physical keyboard

of course, this is true for all shapes that have more than one parameter to enter

I will be grateful for any help, hint, suggestion (new feature) or plugin :slight_smile:

I haven’t ever seen a period as dimension separator.

The parsing of length inputs is already not trivial (supporting combinations of languages & locales & decimal separators). Extensions also have no access to customize (hijack) this.

I think instead of suggesting an implementation (of which you might be the only user), it can be helpful to take a step back and take a look on the actual problem you want to solve: You have a virtual keyboard with not enough buttons.

  • Does the keyboard have alternative layouts?
  • Wouldn’t it make sense to send a feature request to the developers of NumPad for adding customizable layouts, rather than sending a feature request to SketchUp to interpret characters in a non-standard way?
  • Or can you find another, better virtual keyboard that works with your setup?

It is possible to customise these settings but they will then apply system wide, to all your applications.
In Windows, go to Time and Language settings. Click the "Additional date, time & regional settings link. In the dialog that opens, click on "Change date, time or number formats. In the next window, click on the “Additional settings” button and you get this:

1 Like

If your system (windows or Mac OS is set to use the dot as the decimal separator and the coma as the list separator, you can enter both imperial and metric unit in the same way.

The same is true if your system is set to use the coma as the decimal separator and the semi colon as the list separator.

If I use a keyboard with a numerical keypad on my Mac, the key with a coma and a dot (shifted) produces a coma so there is no problem since my system is set to use a coma as the decimal separator and a semi colon as a list separator.

Excel does the same, inputting a coma when I press the coma key. However, I remember that, when using Windows, the coma/dot key on the numerical keypad produced a coma in Excel and a dot in SketchUp. That was way back in the time of version 5 or so. I signalled that in the user forum. Since that time I have been using SU mostly on laptops without numerical keypads and mostly on Mac so I don’t have this problem.

I wonder if someone can do a test using Windows on a PC. I just did a test using the latest version of SU 2021 on my Windows 10 partition on my Mac, using Parallel Desktop and experienced the same problem as before, namely that Excel behaves correctly by entering a coma when I press the coma/dot key on my numerical keypad and that SketchUp enters a dot. Nothing has changed since the last 15 years.

To me this is a serious bug since it slows down numerical input from a keypad since the user has to use the coma key on the main keyboard.

I am using Apple’s magic keyboard with numerical keypad.

Thank you for your answers.

The hardware and software supplier is 3Dconnexion.
I have already written a request for a feature on their forum, but the topic is waiting for approval by the moderator. SpaceMouse product line by 3Dconnexion

I checked the idea of ​​adding a new virtual keyboard under Windows 10 and unfortunately I am probably the first person who cares about the semicolon “;”

There is one keyboard that has “;” and enables free testing, but despite the correct configuration in the program, it does not turn on. You have to manually turn it on by clicking on the icon or by typing the name in the search engine (the alternative is to have it open all the time ;( )

As Dezmo and Anssi wrote, you can change key representations under Windows, but it has a global effect in all programs on your computer.

I don’t know if this answers jean_lemire_1 to the question to test the function under Windows. But I also use this computer for billing in excel. This is where the “normal” numeric keypad comes in handy. Office 2016 made it possible to configure inside the program to enter correctly values ​​with the numeric keypad replacing “.” by “,”

If someone has read a virtual keyboard for Windows 10 that can be tested in this topic, I will be grateful for your help. I tested: Free Virtual Keyboard (does not work or execution is blocked in other applications), VirtualKeyboard (does not have a semicolon “;”)

other keyboards in Windows Store do not have (or do not see).

If anyone has a suggestion, I will be grateful for any idea to solve this problem

Are you using a tablet that does not have a physical keyboard?

I use a desktop computer, windows 10. In my work, as an architect, I often enter dimensions that should be precise.

If I were able to work without taking my hands off and touching the keyboard every now and then, it would save a lot of time. Seriously, I often enter different parameters.

Extension lines, offsets, the number of segments or a straight line are not a problem as they only have one parameter to complete. Squares or rectangles, cutting holes in a surface already require a semicolon “;” that a precise shape is created.

Of course, you can always do something simplified when rendering. With projects, this does not pass anymore

How about setting one of your 3d connexion buttons to ;

It is probably the fastest solution for now :slight_smile: thank you