Changes in Entering Dimensions in Version 22.0.353

So I enter dimensions constantly using my num pad… In previous versions I could enter either a fraction or a decimal ie - 5 1/2" or 5.5" and get the correct distance. Its a lot faster and easier to enter a decimal than the fractions, however I need to keep my units as fractions for the woodworkers who work for me who use tape measures. In this new version I cannot enter decimals while using fractions for units for some reason and its incredibly irritating to have to add a space and a “/” since it requires 2 hands for the space bar and the “/” is in an awkward position on the num pad. I know that seems like 1st world problems - but when you spend as much time drawing as I do and speed is how you get paid, its really really annoying. Anyone know the answer?

Secondly… dimensions used to be separated by a “,” - in this version they are separated by a “;” . After 10 years on sketchup my brain is having a hard time making the switch since I automatically hit the “,” button. This means I am constantly having to reenter the dimensions. Any help on how to fix either of these would be really appreciated.

There’s been no change in the method of entering dimensions in any version of SketchUp. You can enter decimal inches while working with units set to Fractional if you wish. If it’s not working for you, there must be a change in your process.

Here is an example with Units set to Fractional as evidenced by the dimensions in the model space and drawing a rectangle using decimals.

This has to do with the locality setting on your computer. SketchUp picks that up from the operating system. If commas are used as the decimal separator the semi colon will be used as the dimension separator. That would also explain why you aren’t able to enter decimal units. You’re typing a period when SketchUp is looking for a comma. Changing the locality setting for your computer to US, for example will restore these settings to what you are used to.

Your thread title indicates version 22 but your profile says 23. Which one is it?

1 Like

in Mac os preferences / accessibility / language and region.
you can check if your region is the right one, and you can choose numbers format.

Capture d’écran 2023-04-14 à 20.40.31
if your decimal is a , then the separator will be ; but choose a simple . and I guess it should do the trick.

Capture d’écran 2023-04-14 à 20.42.41

(I just tried, asked mac os to use a dot as decimal, and voilà)

You are a genius, this also solved why my date entries have been defaulting to the UK setting of Day month year. Which in honesty makes a lot more sense lol.