Typing measurements?


#1

Hello…How do you type measurements on your english computers?
Do you also use Semicolon…?

For rectangles, Here in Denmark for example, we have to:
Hit “R” for rectangle
draw out/start a arbitrary rectangle
and
type: 30;50
and hit “Enter” to make the rectangle jump to that size.

I tried to help a user with this,
but his Sketchup will not even do the above…?

Hope someone here
will help me understand this better…

Greetings for now…Jakob.


#2

Jacob,

This relates to the number format used in your country specific version of the operating system.

In the US (and a few other countries), we write “ten and a half” in decimal: 10.5
Outside areas that use this convention, “ten and a half” is written: 10,5

Now on to Sketchup. In countries that use the period as the decimal separator, SketchUp measurements use the comma to separate values. In countries that use the comma for the decimal separator, SketchUp measurements use the semicolon to separate values.

So you “30;50” would be entered as “30,50” in countries that use the period as the decimal separator.


#3

Hello…Thank You for a quick reply…!
A country that uses period as decimal separator…
This means you can then use the comma on the numeric keypad…?
That would make so much sense…!

I installed the English version of Windows,
to have english shortcuts
and then istalled Danish Keyboard.
But, I still can not use a comma as separator.

Well well…will try again…
I will install US keyboard.

Thank you “sjdorst” for helping…!


#4

Jacob,

Even the English version of Windows can have either number format. Buried somewhere is system settings (in Windows, not SketchUp), you’ll find something like “number format”. Try finding - and changing - that setting to be able to use the comma on the numeric keypad.

I’m sorry, but I don’t know exactly where to look in Win 7 (which, per your profile, is your operating system).


#5

Hello…yes i am in the control panel,
under change keybord settings…
will search here…
First I need to find the english keyboard,
to see, where different keys outside qwerty are…


#6

I just searched on Windows 10. Thought that what I found would help in your search on Windows 7

From the Control Panel, click on “Clock, Language, and Region” - giving a popup window where you can change the “Format” - yours is probably “Danish (Denmark)”.

At this point, you have two ways to change things:

  1. Change the “Format” field to “English (US)” - this will change a LOT of settings - and you may not want to change anything other than the number format. So …

  2. Instead of changing the “Format” field, click on “Additional Settings” - which yields details about how your numbers are formatted. The three that you’ll need to look at are:

“Decimal Symbol” — Yours is a comma, change to period
"Digit Grouping Symbol" — Yours is a period, change to a comma
"List separator" – Yours is a semicolon, change to a comma

Note that the “Digit Grouping Symbol” is not necessary for entering numbers larger than 999 - it’s a display only property, so there’s no problem using the same thing for the “Digit Grouping Symbol” that you use for the “List Separator”


#7

It’s more likely you’ll find what you need under Region or Language settings. And if you use the option to change only the number format (as I outlined in option #2 above), you can keep your Danish keyboard and change only how lists of numbers are entered.


#8

Hello…Yes, I was looking in the formats menu window…!
I will try out thes steps above
and see if I can make the switch.

Thank You sjdorst, for All your help and time…
It is great to have this forum…
and get help from a more advanced user…!


#9

restart SketchUp for going the changes made in the Windows local settings into effect.


#10

Good catch! Since I’ve never needed to actually do this, I totally forgot that a SU restart might be needed to read the new OS settings.


#11

Hello there

I have a nother question for this.

I need to change the number seperator from ; to * (on the numpad.)

I that possible? Thank!


#12

Not from within SketchUp.

The number separator is determined by internationalization settings at the operating system level. On Windows 10, find this through:
<Start Menu> --> Settings --> “Additional date, time, & regional settings”
This will bring up the “Control Panel > Clock and Region” window. Now click on
“Change Date, time, or number formats” bringing up the “Region” window. Click on “Additional Settings” and you should see something like:


I’ve highlighted the setting you need to change in yellow. To change it, just enter the character you want as your list separator, then click the OK button.

Note that this might have unintended consequences - especially in other programs! The * character is often used for multiplication. Don’t be surprised if, after making this change, other programs that allow you to embed in-line computation in text fields fail when you try to use multiplication!

If SketchUp is active when you make your changes, you’ll likely need to quit and restart before the change is recognized by SketchUp.


#13

Okay… Thank you for the very detailed answer. I think i will have to use ;

Changing the system settings like that, will problebly do things worse other places…

Thank you. :smile:


#14

I had the same problem.
I used a small program named SharpKeys to allocate the , to the . on my numeric keypad.
That works great and it also saves time and irritation in changing windows settings I think.

Hope this might help.
P.S. I also used it to set my CapsLock as Shift :wink: