Measurements separator


#1

Why does the measurement input sometime require a comma between values, and sometimes a semi-colon? Using SU Pro 17 on a MacBook Pro 2,2 gHz processor.


#2

In the US and a few other places, numbers are normally written with a decimal point between the whole part and the fractional part. But in most other places, a comma is used to separate the whole from the fractional part:

  • Pi = 3.1415 … (US and a few others)
  • Pi = 3,1415 … (Most other places)

If your computer operating system’s “Number Format” setting uses the comma for this separator, then it is unavailable for SketchUp to use as the value separator when you enter measurements since it’s in use as the decimal separator. This is when you need to use the semicolon as the value separator.


#3

It depends on the locale. USA and UK uses dot as decimal separator and comma for value separation while most of the world uses comma for decimal separator and, in SketchUp, semicolon for value separation.


#4

Hi, thank you for replying. What is really intriguing is that earlier this morning I had to enter a comma as the separator, now it requires a semi colon (:wink: ? The computer has not been switched off since this morning and I have not changed any settings. I dont mind using either… it is just irritating that the software ‘changes it’s mind’ like this :slight_smile:


#5

it’s about 50/50 have a look here for another opinion…

john


#6

… another thing, is this predictive text … I am not ‘winking’ at anybody. When I type a ‘semi-colon’ with parenthasys, it changed into a omicon !


#7

SU’s native tools should always use your system separator, but some 3rd party Extensions may require the change…

john


#8

You really mean “emoticon”.

To suppress the nifty forum features, use an escape character (a \ “backslash”).

Ie:

 ..., now it requires a semi colon (;\) ?

… will render in the forum as:

…, now it requires a semi colon (:wink: ?

Basically you are “breaking up” the emoticon codes.


#9

This topic was automatically closed after 91 days. New replies are no longer allowed.