Using Layout to create an elevations drawing - a few "WTF's?"

First off, I don’t have to use it very often (once a year?) so I’m no expert. Having set out to make a video with iMovie once long ago and managing it within a few hours even with a backing soundtrack synced to clips and movement, this programme seems to me to be about as far from intuitive as you can get. That said, I eventually figured out how to create a drawing last year by creating a initial template drawing from one parallel proj’ view in SketchUp then sending the other 3 views after, first to their own template, then copying those and pasting into the intial template drawing. It might not have been the best way to do it but it worked.
I tried to work this way today and instead of pasting in the first additional copied view, it would paste a copy of the initial view… First “WTF?”
Some time later, having tried a number of times to paste in the view, it decided instead that it wanted to copy the text of the scale I had selected in the ‘SketchUp Model’ dialogue box!!!.. Yup, it pasted “3/16” = 1’-0" (1:64)"… Second “WTF?”
Finally, I looked for a tutorial on creating elevation drawings and discovered that TheSketchUpEssentials fella showed how to copy multiple viewports from the initial drawing then selected scenes from a right-clicked drop-down menu. So I created a bunch of scenes, created multiple viewports then went to select a different scene = no option other than ‘Last saved sketchUp view’ which was checked. “WTF?” #3
By chance I noticed that, just above ‘Scenes’ there was an option ‘Standard Views’ so I tried selecting a couple and lo and behold, the different views of the model! Awesome… 20 minutes later I had a drawing with direction labels, windows greyed out and a block of black where the ground is.
Then I try to alter the text in my title block and when I change ‘Truss elevation’ to ‘Elevations’ I get the former greying out as I type but when I click out of the box, I get the two different versions overlaid over each other, equally black and completely illegible, rather than the original disappearing! I had already done this on a couple of other drawings without issue… Yup, “WTF Layout?”
Anyone able to shed light on why these utterly random, inconsistent PITA’s happen? Cos I’m about to throw the laptop out of the window and go back to drawing board and pencil.
Thanks

Oh, additionally, now it won’t let me delete my title block (which I copy and paste from one drawing to another - Yes, I should probably should create my own template with a title block and use that but still… my excuse - it hasn’t seemed to be worth doing for the few times I need it)

WTF are you pasting from SketchUp into LayOut. That’s not the correct work flow. You should either use Send to LayOut or File>Insert to get the SketchUp file into LayOut. The first viewport will show the scene that was active when you last saved the SketchUp file.

Share the LayOut file.

WTF. Did you update the reference in LayOut after you added the scenes and saved the changes?

If you use the correct workflow you don’t need to select the standard view. You just select the scene.

It’s all user error. don’t throw your computer out the window. It doesn’t deserve that.

Probably because the layer that the title block is on is locked. Again, share the LayOut file so we can see what you’ve got and give you some specific guidance.

Thanks v much for the prompt response but:

I didn’t copy and paste from SketchUp. I sent to a Layout template THEN copy/pasted into the first Layout template. This might not be the correct workflow but again, it worked just fine last year.
I don’t know what you mean by ‘updating the reference in Layout’
Sounds like it is mostly user error but I’d love to know how/why scale text from a dialogue box gets pasted into a drawing…
I have no layers (another user error perhaps) that could be locked
Could you clarify how I share a Layout file please?
EDIT: I fixed the Title block issue by deleting the number of copies there were on the drawing (again, WTF?) and re-copying and pasting. The title block copied from the same drawing had the same issue so deleted that immediately. Tried pasting in another one from another drawing and it worked fine.

Drag and drop the LayOut file into a reply. If it’s too large for that, upload it to Dropbox and share the link.

Well, for a change, that couldn’t be easier… Thanks
503ELEVATIONS.DWG.layout (800.1 KB)

So in the LO file you uploaded, the SketchUp file is from before you added the scenes. After adding the scenes and saving the changes you can right click on a viewport and choose Update Model Reference. Then you’ll be able to choose the scenes as desired.


Last saved SketchUp view is not a good thing to use for viewports in LayOut. If you go back to the SketchUp model and make edits but don’t manage to get the camera positioned exactly the same as it was, the viewport will change what it displays to match the new Last saved SketchUp view. That will just create work you don’t need to be doing and waste time.

Take a look at the attached LO file. I’ve opened the SketchUp file changed the style to get rid of the sky and colored background, and created four scenes named to match the views in your LO doc. Then I corrected the viewports to use the appropriate scenes. Look at the SketchUp Model panel in LayOut as you select the viewports. Notice that the Camera properties have not been modified. This means the viewports are still tied to the scenes in the SketchUp model. The style is also not modified and comes from the SketchUp model.

I replaced your dimensions with ones that are actually tied to the Sketchup model. This means that a change in the model will be reflected in the LO file. For example if you change the height of the ridge on the roof in the SketchUp model the dimension will show that in LayOut when you update the reference.

I also added some layers in the LO file for the different entity types. Note that the dimensions layer is above the viewport layer. This prevent the dimensions from disappearing behind the viewports.

As for the scale listed in the title block, it isn’t tied to anything in your model so whatever you copied from the other LO file is what that text says. I edited it to match the scale you had selected for the viewports so it is correct. I also ungrouped all that title block text so it’s easier to edit.

503ELEVATIONS.DWG fixed.layout (448.8 KB)

Really with the correct workflow you shouldn’t have any WTF moments at all. Set up scenes in SketchUp for the way you want to show the model in the document. Create a template in LayOut with the title block stuff and layers that work for your projects. The template can include anything that is standard from one project to the next. The time spent setting up the template will be repaid many times over as you work on new projects.

By the way, in your SketchUp model file I noted that you have incorrect tag usage. ALL edges and faces should be created AND remain untagged. Only groups and components should be given tags.
Screenshot - 9_30_2022 , 5_39_10 PM

And it’s a good idea to purge unused stuff from your SketchUp models once in awhile. This helps keep the model streamlined and light. In this case your model isn’t that heavy but it’s still a bigger file than it needs to be.
Screenshot - 9_30_2022 , 5_39_29 PM

Wow - thank you for taking the time to go thru all that. That’s going to take a bit of me going thru to fully understand - I clearly don’t know how to set up an efficient LO drawing off a SU model yet.
I was hoping to find a ‘workflow’ demo on YT but that video on the channel I mentioned didn’t tally with what I was seeing available - I had no intention of using ‘Last Saved View’ but, as mentioned, that was the only option available even after having created a scene for each elevation. I’ve since discovered the Layout Essentials in the SketchUp campus so I will go thru that when I have time.
OK, that comment about edges and faces in the SU model is not something I was aware of - I often wondered why things I selected didn’t show up as belonging to a tag (or layer) I always assigned them to a layer (assuming that anything tagged in a group should be tagged) when I found them because I had been led to believe that they were related to issues I’d have when hiding tagged layers and parts of a tagged layer being left in view - I’d then erase those bits but they’d only disappear (remaining highlighted in blue but ‘inert’) if I closed the file and reopened it.
My error re: the scale - I was in full-on WTF by that point so had missed it - but that is a different issue to the contents of the dialogue box getting pasted into the drawing rather than the drawing I’d JUST copied… I’m still none the wiser about that though I guess it is irrelevant now I’m aware of a better way of setting up a drawing.
Thanks again for your input

I wonder if any of this relates to your strange transparency issue.