Using Layout on a MAC that is using French language OS

Hi there. I am using Sketchup and Layout for over a year. When I open a new project in Layout, it gives me a choice of only 7 templates, all metric in A3 or A4. I live in North America and work in imperial units. How can I access the imperial templates?

Do you not see the Letter templates? The standard templates are held inside the package. It may be worth downloading SketchUp again, in case LayOut is missing some files.

Or, go into LayOut Preferences, Folders, and click on the Restore Defaults button.

If you do need to get the SketchUp installer, this link will immediately download the 2020.2 Mac disk image:

Hello Colin. I just tried what you suggested, but it did not succeed. When I was running the English OS, I could see the letter templates, but they disappeared once I switched to the French OS. Note that I see all Layout menus in French now. When I go into LayOut> Preferences, I see the following lines (the first in black, the second is greyed out):
/Applications/SketchUp 2020/
~/Library/Application Support/SketchUp 2020/LayOut/Templates

I don’t see them in that (packaged) folder (not in other languages, too). Templates are nice to begin with, but it might be better to create you own. They would wind up in the second line greyed out location name.

You could alter the package to have them in the French resources as well.
First quit LayOut, then open finder and go to this path:

/Applications/SketchUp 2020/

Copy the whole folder and search for the fr.lproj folder and paste them

Each reinstall would restore them, but around that time, you probably would have created your own templates!

It is best to create a folder that is more accessible by other future versions, too.
eg. you can create a folder like this:
/Documents/SketchUp Resources/LayOut/Templates
And then add that folder location in [menu] LayOut > Preferences > Folders

Interest that when I set LayOut to run in French it still uses the en.lproj files.

What Mike said will solve the problem.

I had changed for the app only, and then it would show only the french resources.

Mike, Colin,
Thank you very much for this guidance. I do not consider myself a computer wizard, so it will take me a bit of time to explore what you told me. I live in near the east coast, so I will continue this tomorrow.

I will give you a variation of what Mike said, that would be easy enough to follow, and would be less risky:

  1. In Finder, on the Go menu, is Go to Folder…
  2. Copy this text, and paste it into the text field you will be shown:
/Applications/SketchUp 2020/
  1. In that folder, select Templates and type Command-C (or Edit/Copy).
  2. Find somewhere handy, say your Documents folder, and do a Paste.
  3. In LayOut Preferences, Folders, Click the + button next to templates, and point to the copy of the English Templates that you made.

That should add the English templates, without having to modify LayOut.

1 Like

I bow to your expertise and experience. This worked! Thank you so much.