Using external components

Can someone explain what I am doing wrong here, if anything?

In most CAD systems, when you pull in an external component, you bring it in with a pre-set origin point. That allows you to place it in one smooth operation. But when I do it in SU, I get this:

Import component

The original file looks like this:

There is nothing a long way off to the bottom right which seems to be the “handle” SU is using.

OK, so it isn’t a huge task to drop the component randomly and then use Move tool, but I suspect it isn’t meant to work like this. Operator error probably, but how?

SketchUp should be placing the component at its origin. Are you seeing this consistently? What components are affected?

Yes, it’s consistent. I think it affects any component I pull in. Is it a Mac thing?


Can you share that, please?

I have amended that one since your post to see if I could put it right. But here’s another one that does the same thing.

Internal door (DC).skp (81.2 KB)

This component behaves normally for me. Interesting…

What do you see if you turn on the “Show component axes” and try to insert this door? Do you see it its axes are not in a right place?

This is what it looks like if I switch on axes.

I see you are Windows. That’s why I asked if it might be Mac related.

Since I did not find any “problem” with it, it is possible… but strange.
(In windows: Time to reboot the computer… :wink: )

BTW. I meant to switch on the “Show component axes” in a model where you are inserting into this door… and see the axes of the inserted one.

I presume you mean when you insert the door into a model?

Here’s what happens:

Import component2

You can see that the insertion point is responding to lines and surfaces but the actual handle is (and I think always is) somewhere off to the right.

I notice that, like you, @ene_su uses a PC, although many of the SU team use Macs. So it would be good to hear from another Mac user.

AND switch on the “Show component axes"…

Never-mind. Seems to be a Mac behaviour. Hope someone else can help…

I also tried that. Makes no difference (apart from showing the axes on each inserted component).

There might be a Mac specific bug in how the insertion point is used. Some years ago the insertion point feature was removed and components were supposed to only use the local axes as insertion point. I’m investigating further.

I have been unable to reproduce the issue on my Mac (2019 16" MBP, macOS 11.4, SU 21.1.278). The insertion point attaches to the lower left corner of the door when I place an instance. I wonder if it is related to how the component got into the model. I opened the downloaded component skp file in an empty model, then deleted the instance leaving the definition in the components window. Then I tried inserting new instances and all was well. I did notice that in the attributes for the DC, the Opening_W is the only dimension that doesn’t have cm specified. I wonder if that can mess things up under some circumstances, as I think that means it will be taken as inches?

I can’t repro on Mac either.

Could be worth sharing a file containing the component too, in addition to the component in itself.

I attach the blank template with the component inserted.
CE 2021.skp (177.2 KB)

And here is what happened when I inserted it. As you can see, the "handle is accompanied by a plus sign and the name of the component. It always seems to be to the bottom right of the component.

Import component3

I’ll see if that makes any difference but I think this occurs with all components, not just DCs.

The reason Opening_W doesn’t have cm specified is that it is a formula:

However, Lining_T and Offset are not formulae and yet have no cm definition. If I try to add it, it gets highlighted in red.

The fact that it has always been like this for me (as far as I remember) and yet @ene_su cannot reproduce it on a Mac may suggest that it is template related. When I say always, I mean across every version of SU I have had and across at least three different Macs.

So I have just tried it with the shipped SU Architectural template. If I use the Component Browser, there is no difference. If I use Import, it works as it should.

Import component4

Just thinking loud…
The insertion point looks good, “only” the mouse pointer get an offset from it. It’s like the window you’re moving from is in part on another monitor (with other resolutions) and the cursor get its positon from that one… or according diferent resolution…
Or an other instance window of SU is opened and somehow the mouse bonded to that…
Do you have two monitors?, if yes can you try to disconnect and see…
I know it’s unusual on a Mac, but have you restarted lately …?