Component Visibility


#1

Hello folks. Relatively new to Sketchup and having a problem with placing my components. I must have changed a visibility setting, as when I try to place a component, it is invisible until I click and place it. In otherwords, I can’t place it really, I have to insert somewhere and then place it. Very frustrating and time consuming. Can anyone help me get this back?


#2

This could be a graphics card issue. What are your machine and graphics card specs? Also are you using SU 2018?


#3

Can you share an example component that does this?


#4

Is it possible that you have zoomed in too much and the component is actually off screen.


#5

Box asks a good question. If you are trying to insert a component from the 3D Warehouse or even one of your own components from the Components window or Import, the component’s origin is the insertion point. It’s entirely possible that the origin/insertion point isn’t close to the component’s geometry. If you’re zoomed in too close, you might not be able to see the geometry when you have hold of the component’s origin.


#6

It is SU2018, but has been working fine until today. I think I must have
accidentally changed something…?


#7

It is all components. I don’t see them as I move them out of the components
box and into the model. I only see them once I click somewhere


#8

No. I can go to full extremity of drawing and then move a component in and
all I see is the cross hatch cursor until I click and insert the component


#9

Is it possible they are just being placed at a long distance from the camera? This is what I see when I drag in components.


#10

How did you install SketchUp? Double-clicking on the icon? What kind of graphic card do you have?


#11

​Well that’s the way it has been working for me too. Just like that. But
today I don’t see them moving into the model. If I select a component, and
then move the cursor to where I want it, nothing shows but when I click the
mouse the component does get placed where I had the cursor. It is not a
long ways off. I can use it this way but with difficulty. Something has
changed…but I can’t figure out what​


#12

Might be that some graphics optimizations are kicking in. How big is the file? Do you have shadows or transparency enabled?

One thing to try would be to close all your files and try a simple test with a blank file and a small (polygon size) component.


#13

Well it was a strange one. After a computer re-boot it is all performing
normally again so sorry for the trouble, however maybe helpful on the forum
if others encounter this. Many thanks to all for your reponses


#14

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.