Component drags in not on cursor position

When I drag in a component from the components window, it does not place it where the cursor is positioned. It places it a large distance away from the cursor position! Help!!! If I zoom in a lot, and I mean a lot, i can get it closer to the insertion point…

Is this one of SU’s default components or is it from another source. It could be that the component’s origin/axis is located far from the geometry. When pulling a component from the Component Browser, SU grabs it from the component axis.

If you can, upload the component so we can have a look. To isolate the component for upload, simply right click on the components and select Save As… This will save the component our as a separate skp file. Upload this file to your post and we will have a look.

CD

The component’s axes might be far from its logical origin in that case select the instance and change its axes using the context-menu to somewhere more logical - delete the flaky instance and insert a new one… is that better /

But I suspect another cause…

Switch on your model’s axes.
Is the awkward component snapping to the axes’ origin, and therefore giving you no option to locate it manually ?
This suggests that the component is geo-located.
Edit the SKP belonging to the component and in Model Info switch off geo-location.
If you downloaded it direct from the 3dWH save it out as a collection and the process its SKP file.
This error occurs when you [or someone else!] unthinkingly save a model that’s been geo-located as a component, and try to reuse it…

1 Like

|960px;x723px;
Your component Axis?

It’s any comonent including the SketchUp built components like Sang…

Stacy.skp

Stacy.skp (88.9 KB)

Here’s what it looks like as I drag in the Component…15%20PM

Hi Tig! Big Fan of your Extensions!
It doesn’t seem to be Geo-Located…
It does it with every Component, even the default Components such as Susan or Sang.
Model Info says the file has not been Geo-Located…
It’s weird!

When I insert Stacy she comes in with her component origin attached to the Move tool as expected.
Insert

Please complete your profile with SketchUp version, license type, OS version and Graphics card. That information helps us help you.

Why can I only see little bit of the red axis in your screen shot ? Go to “Camera” and click “Zoom Extents”. It will bring the origin point and axis’s into view. Select Sang , Stacy or whomever and you should be able to slam her right down on the origin like DaveR showed.

Did’nt work…

Thanks! I updated my Profile…
Here’s a better screenshot of what is happening.


Thanks for your help!!!

Does this happen with any component you bring in from the Components panel?

Plan B

It might it be a graphics-card issue ?

Try updating to the latest drivers - if that’s possible on a MAC ?.
Try setting Preferences>OpenGL NOT to use Fast-Feedback - it’s not a good permanent fix but at least if it improves things it’s a clue !

see if the problem exists in a different ‘Template’…

one of the standard ones would be ideal for others to double check…

john

I don’t normally comment on mac topics but I have seen something like this on a PC with a touch screen.
Do you have an Apple Pen or whatever it is called? Might be throwing the calibration out.

Well I’m puzzled… Went ahead and downloaded the model you posted. When I opened it nothing was in view. Hit zoom extents and Stacy was front and center on the origin. Imported a bunch of models was able to place all on origin. Not able to reproduce your problem on two different mac’s. Only thing that was a little odd is Stacy had been exploded…

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.