Components not visible- can select it but can't see or edit it

Hi all, I have a component I keep trying to import, but it is not visible… I can select it with the blue box but can’t see it; I think it may have been tagged with another group which was since deleted so I keep re-importing it but same happens. When I select & right click to see if it is hidden it disappears…
Tried to upload the model but it is over 16MB- could this be a reason, i.e model is too large?
I’ve already checked scale of model and it’s fine…
Any clues please?

Upload the file to Drop Box and share the link. I expect there’s a simple fix but seeing the model file will prove it.

Thank you Dave

What’s the component you are trying to insert?

By the way, I fixed the incorrect tag usage in your model.
Screenshot - 7_1_2022 , 9_53_24 AM

The missing component isn’t that blue thing at the origin is it? There are actually three of them stacked on top of each other. Here I’ve spread them apart.

Aha Yes! Thats the one… Thanks so much.
So how did you find out there were 3 stacked together & fix it?

I’m only 2 weeks into using sketchup… what do you mean by the incorrect tags in the model please?
Also am I able to access the corrected model from you? Thanks again

I selected the component and looked at Entity Info. It showed there are three of them in the model space. You indicated you had tried to insert a component multiple times and I didn’t see this one anywhere else so I guess they were in the same location. I just moved the selected one over and clicked again in the original location and moved that selection down. Presto! three of 'em visible.

Tags should be put on objects (groups and components) while all edges and faces (geometry) should be created and remain untagged. Tagging geometry winds up creating problems down the road (as it did for you with the “missing” component and makes you work harder than you should need to.

Remember that tags do not provide separation between things in SketchUp. For that you need to use groups and components.

I would suggest that you take some time to go through the SketchUp fundamentals at learn.sketchup.com

Here’s a link to your file. I deleted a couple of copies of that component.

You’re a Star, thank you :slightly_smiling_face:

1 Like