Help; I cannot select the component that I have just created

Hi all,

I have an interesting case that I hope someone can help me with, because it is annoying the living hell out of me ^^. My problem is as follows;

  1. I make any shape and select “Make component…” from the context menu
  2. I give the component a name and save it (e.g. Component X)
  3. Select something other than the Component X that I have just created
  4. Click anywhere on Component X

Now, I expect that after 4, I select the whole Compenent X, however, I just pretends like I never have created the component and just selects whatever element of the component that I clicked on.

I have already tried a few things;

  • Restart doesnt help
  • Component X does show in the “Components” Default Tray, and if I select it there and paste a copy Component X in my sketchup model, click away, and select it again, then it DOES select that component. However, it still does not recognize the original shape that I used to create Component X as a component. This of course doesnt solve my problem.

Does anybody know how I can fix this? Is there a simple setting that I missed (and perhaps accidently got me in the state I am in now?) Thanks a lot!

Cheers,
Bram

In the Make Component dialog, tick the box down the bottom that says something like, replace selection with component.

3 Likes

Perhaps you could share the SKP file so we can see your setup?

Just as a guess, you’re only selecting some of the attached geometry when creating the component and you haven’t got Replace selected checked in the Create Component window.

Thanks, awesome! This worked

1 Like

And in addition: by selecting the new drawn part with ‘triple click’ on one of the edges or faces, you will select all ‘attached’ loose geometry.

Sometimes you don’t want that. The box remembers it’s last state so you can easily divide attached geometry with a double click and a triple click.
Comp Split

yeah, I sometimes forget what I put in the box…
stateofmind

credits for model here:

1 Like

Cute.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.