Component (DC) strange behaviour at insert


#1

This is a tricky one, I think.
I did a bunch of dynamic components for my pupils, lot of work (on MAC), put them in a local folder (Dropbox).
They all have size options the user can set.
All went well, but now they act strange when I try to use them on PC. Having loaded the local collection, clicking one in the component browser makes it pop up near the axis origin; it cannot be put at the required spot. AND the view zooms to frame it tight.
Funny thing is that, once they are in, from the “In model” pane, they insert as usual, albeit making a copy adding #1 to the name.
It happens even with the simplest combo of the set.
I tried to reproduce the problem with a test compo, couldn’t.
Hoping someone encountered this before and found a solution, so to not have to redo them all.


#2

how do they look in Outliner, i.e. are they nested?


#3

Hi John !
Well, opening one shows the name (with the little house in a square icon just before) and then all the parts indented, preceded by their triangle to expand if they have subparts

So I would say no, It is not nested.


#4

I don’t use them enough to know the details, but I know that they can come in as either an editable component or an active DC…

hopefully one of the experts like @pcmoor or @jim_foltz will pop along and explain to us both…

john


#5

Imported SKP components that are immediately snapping to the ORIGIN instead of allowing you to insert them, suggests to me that the original file used to make the SKP was geo-located.
That’s a known cause of this behavior.
The Template used to make components should NOT be geo-located.

All is not lost… if a geo-location setting has been passed onto the component SKP it is fixable.
Open each flaky SKP and use Model Info > Geo-location to ‘unset’ it.
Save it…

All should now be well ?


#6

Indeed TIG. That did it.
Boy! You sure know your SketchUp.
Thanks a bunch !