Using 2020 pro with 4k double monitors

I recently upgraded my two monitors to 4k(dell ultrasharp 27") connected to laptop.

Windows display setting recommended resolution is 3840x2160 and recommended % for text, apps, and other items at 150%. everything including windows icons, web surfing and youtube videos are perfect but sketchup.

My problem is when you move around the default tray from screen to screen.
First, its very slow and have delay moving around in single screen.
Second, when you move from screen to screen, it stuck at some point not moving until it jumps right to the other corner… and vice versa.

I believe this is not my computer or monitor but its sketchup.
is there any setting that I need to adjust, or is this something that we’re waiting to get upgraded?


You have the same 2 x 4K screen setup that I use.

Are you using a separate instance of SketchUp on each screen or just separating the trays onto the 2nd screen?

I recently gave up trying to run 2 instances on separate screens as it resulted in instant crashes.

I used to copy and paste between instances but now I have to rely on the import function which requires a bit more work.


How are the monitors connected? Is the laptop screen also open? What graphics card is being used (Window menu>Preferences>OpenGL>Graphics card details). Some laptops don’t use their dedicated graphics for external monitors, or some “docks” used to connect external monitors don’t run OpenGL. Updating all drivers and firmware might help. Is the laptop also a Dell?

Sorry for the lacking info.

I am using lenovo ThinkPad P53.
Currently, my monitors are directly connected to the laptop with thunderbolt 3 connectors(usb-c)
Graphic card information from OpenGL Details window shows : Quadro RTX 4000/PCIe/SSE2

What I noticed is opening up Sketchup Preference tab and moving around inside one monitor or moving around from monitor to monitor doesn’t have any problem. it moves as I move my mouse, and no problem crossing between the screens. It’s just a Default Tray that slows down and doesn’t really follow my mouse.

I found out that this is because of 4K screen scale and layout.
I have text, apps size set as 150%(Recommended) for both monitors.
I dropped this down to 100%, which is almost unable to read with small fonts but the default tray window was moving from screen to screen with no flickering and jumping.
It’s still noticeably slow to drag around…
As more and more people upgrading monitors to 4k, I guess SketchUp team should be aware of this and make proper updates.

Have you tried 125%? I have a single 4K monitor (32") and I find 125% small but readable.