Urgent sketch up file may be corrupt help asap

Hi I am an interior architecture student in desperate need of opening my file.

It was just working last night and I came to uni and everytime I open the file it says “cannot open file”, I have tried everything, it opens other sketch up models just not this one, also tried it on the uni computers, it simply won’t open, I’ve renamed, moved etc, please help or let me know if anything can be done.

For us to help, you need to share the file here. If it is less than about 16MB you can drag’n’drop it directly into a reply. If larger, you’ll need to upload it to a file sharing server, make it public readable, and provide a link in a reply here.

There are several kinds of model issues that can make a file unworkable, and people here know how to identify and fix them. But if you are getting a can’t open file or doesn’t appear to be a SketchUp file error, an appeal to the Trimble team is the only path, and their ability to salvage part or all of a file depends on the details of the corruption.

The most common cause of file corruption in SketchUp is saving to somewhere other than the computer’s internal drive. Yeah, that shouldn’t be a problem and many people get away with it for a long time before some coincidence of events happens and fries sketchup’s save logic. The devs are quite aware of this but haven’t yet nailed down the cause.

I’m sorry how do I send the file through that sharing option? I really wouldn’t know how to do that

@slbaumgartner hi I think I’ve done it let me know what this does, thank you.
Transfer - Dropbox

I tried but couldn’t open it. Maybe @colin can manage it when he gets a moment.

@DaveR thanks for trying, that’s the issue you see I can’t even open it myself or view it or anything, I have no clue what to do.

At this point wait to see if Colin is able to do anything with it.

Where have you been keeping the file as you were working on it?

@DaveR , well I initially had it just on my laptop normally, however in order to use Vray I need to use it on the university computers, so I copied it to my external ssd drive and worked on it through that, and it also saved in the sketch up cloud as I was logged in, it was working perfectly fine, but when I went to open it via this drive as that’s where I had saved it, it refused to open, now I need to use the uni computers still but I’m scared the same thing will happen.

The file data looks ok, but may be truncated. Should the file be about 48MB, or bigger? How big is the .SKB back file?

My usual ways of recovering something haven’t worked.

@colin I don’t believe I have an skb file it is just skp, so I’m not sure how to check that sorry, the skp file is 46.4mb.

The Create backup preference is usually turned on, and when it is there will be a file in the same folder as the SKP, with the same name, but with .skb as the file extension. It won’t show in the SketchUp File/Open dialog, but will show in File Explorer.

@colin ah yes i see it thanks , it is the same size, what should I do?

You could let me try that file as well, in the hope it’s less corrupted.

@colin Okay here is what i believe is the file.


@colin hi colin I see you’ve opened the file, I was wondering how it went?

The skb seems to be in better condition than the skp, but still I can’t recover anything from it.

I have asked developers to take a look at the file.

@colin thank you, do you know how long that will take?

I understand that you have versions of the same file in four(?) places: Your computer, your external drive, your UNI server and even Trimble Connect(SketchUp Cloud). Are they all equally corrupted? I would guess that the damage has been done in one of the transfers between platforms.

@Anssi it is in 3 places the uni one is just from my external drive plugged into the computer, but yes that is correct they all say the same thing, is there anything that can be done?

If you have been saving to TrimbleConnect it should also carry earlier versions of your file. If that isn’t the case, I would just wait for whatt @colin can do, berhaps simultaneously preparing for rebuilding the model from scratch.