Updating Default Image Editor - Affinity Photo 2

Hi There, not sure if this is a new bug or affinity / Windows 10 / Sketchup incompatibility… but I cannot point my preference to the newly purchased Affinity 2 suite… it was simple before… just tracked down the executable in my program files and “choose” it…
Now, when I track down the lastest Affinity Photo 2 exe… I find that it is no longer in “program files” but in WINDOWAPPS

The Problem is …

this is a protected folder and Sketchup preferences does not allow me to CHOOSE it

and I cannot manually type it into the Default Image Editor field…

I have no idea why W10 installed the executable in the WINDOWAPPS folder… I did a default Affinity Install… it has never done this before… and as you can see Affinity seems to be the only “non Microsoft” program there…

Of course I can work around this by bypassing the Default Image Editor call and edit the image outside of SU actions… but it seems to flag something more…

PS I am using SU 2021 still

Any thoughts?


apparently sketchup is not the only software having issues with this new hidden path.

you might want to try this, someone among their team managed to create a launcher that would fix the issue


Thanks Paul… seems like an Affinity stuff up, still no fix after 3 months now it seems… even though “their programmers are working on it”

Was able as a temp fix to create the batch file on my desktop and choose it from the Default Image Editor preferences and that worked for the moment…

start /b affinityphoto2.exe %1

place that in a batch file and name it what you want!

You’re actually pointing it at the wrong executable.
You want:
C:\Program Files\WindowsApps\SerifEuropeLtd.AffinityPhoto2_200.4.1701.0_x64__844sdzfcmm7k0\App\photo.exe

SketchUp will be able to open that.

For others who have a similar issue with the newer style MSIX or UWP type packages , which are usually installed via the Microsoft Store , this is how I found the link:

  • I ran the editor (affinity photo 2 in this case)
  • Pressed Ctrl+Shift+Esc to bring up the Windows Task manager
  • find the program you want in the list and expand it
  • then right click and choose “open file location”

This then takes you to the folder where the program’s executable is

copy and paste the address from the address bar , in my case :
C:\Program Files\WindowsApps\SerifEuropeLtd.AffinityPhoto2_200.4.1701.0_x64__844sdzfcmm7k0\App

and then add the name of the exe file you want on the end (\photo.exe)
C:\Program Files\WindowsApps\SerifEuropeLtd.AffinityPhoto2_200.4.1701.0_x64__844sdzfcmm7k0\App\photo.exe

1 Like

I was in the Affinity forums yesterday about this same issue. What is happening is the installer is a .msix file, from the Windows Store, is sandboxed. The batch file mentioned by @gsharp is a temporary fix that will break when the App is updated. The path referenced by @Elmtec-Adam cannot be accessed by the system. From the Affinity forum aflaunch.zip (Why are we using MSIX for Windows installers? - Frequently Asked Questions about V2 software - Affinity | Forum) is is in a post from Patrick Connor. I have also uploaded a copy of it
aflaunch.zip (9.7 KB)
Point the file preferences path to this file. I have verified it does work.

I tried it in SketchUp and it opened Affinity photo