Update scenes bugged in 2021

From several menu and mouseoptions updat scenes is not working. Choosing section cuts ON is not set, not from rightclick mouse and not from the scenes menu button.
Even after setting thing corectly and making a new scene the section cuts still are off.


Are you updating the style after changing the Section Cut setting?

Yes, that isexactly the problem, updating is not working from tab/rightclick, scenemanager rightclick and scenemanager topleft button.

If you make a change to the style properties including changes to sections you should get a warning message when you update the scene.
Screenshot - 4_9_2021 , 6_21_24 AM

If you aren’t getting that warning you must have disabled it. Go to Preferences>General and click the button to Reset warning messages.
Screenshot - 4_9_2021 , 6_20_24 AM

Its not a styles problem. This nag is switched off because of irrelevance. Styles i manage elsewhere.
Problem is the scene does not update. The view setting will not stay. When section cuts are switched on, this refuses to update into the scene. Update scenes seems to be broken.

Welk OS heb je precies? 10.15 of inmiddels 11.2.3?
What are those settings in the scene ?
Please post an example to reproduce.

Mike, running 10.15.7 since shortly. Installed 2021 after this. Since some of our macs are 2012 or something 11 will not come for maybe many years.
The problem file(s) are big, so a link to one of them.

Scene I am working on is “tech wand”., to specify locations of wcd, water etc.
The way it is now it is unusable in layout.

Does this look like what you want to have happen?

When I opened the file the style showed that it had been modified but not updated.

I updated the scene and in the process got the warning you say is irrelevant.
Screenshot - 4_9_2021 , 1_01_29 PM

In the interest of time I let SketchUp create a new style rather than go through the existing In Model styles to see if your settings match one of the 48 existing styles.

Although not related, I fixed the incorrect tag usage…
Screenshot - 4_9_2021 , 1_03_31 PM

…and purged unused stuff from the file before saving it.
Screenshot - 4_9_2021 , 1_04_54 PM

1 Like

Its the scene. The style is irrelevant. When i open the file the section cuts are invisible, the view is outside the building. When i switch section cut on and try to update the scene, the scene is not updated, because the next click on the scenebutton goes back to no section cut. File savecdoes not help.
I only tag when needed forvscene choices, still not used tonthe silly tag name. Its still layers for me.
Why are you referencing to the styles or why would a section cut be part of a style? Seems utterly illogical to me and when it would be part of styles it would create a big mess in the styles dept, as you found out. I dont remember it ever was so?

No. The style is relevant. The Section cut display is a style setting. Since you aren’t updating the style, you aren’t updating the section cut display state. Update the style or create a new style as I showed and the section cut will be displayed.

1 Like

Sigh. This has been developed by a developer, not a logical user. I used this for years, has it changed or am i becoming too old? Have default ticks settings been changed? Why can i switch this on at two locations? Itvreminds me of windows,…
Tx Dave, the why and theclogic baffles me.

It’s been this way for years and years. To me it makes sense to have the sections as part of the style settings. Even more so now with style choice being easier to set per viewport in LayOut.

As I wrote before, if you’ve disabled the Style Change warning, you should re-enable it.

I can manage with that but I think that another possibility would be to make this a scene setting, like Active Section Cut. I can see some reason behind that too.

That could work but then that means I need two different scenes to use for viewports in LayOut. As it is I can get an elevation and a section view from the same scene simply by choosing a different style in the SketchUp Model panel in LO.

But only a single style… As implied, there is a use case for both approaches. Perhaps I see a style as a collection of settings about what things shown look like, and a scene as defining what things to show and from what point of view, so section cuts might logically belong in the latter group.

Annsi, i wholeheartedly agree, that is the way my mind orders things. Styles are foor looks, colours, lines, textures, etc. scenes are for the what is shown, defined by layers.
Now both are untruly mixed, and also are the cause of my cluttered stylefoldout, (learnt now) where the images do not tell something about sections etc. The ux of this could be improved, its still googly.

I only have one style in my SketchUp models now. I have a set of styles I can choose from in LO. Some have sections on, others off. If I want to show a view with the section plane active, it’s easy enough to do right from LO. But different use cases and different ways to work.

Fortunately in Peter’s case it isn’t an actual bug in the software.

One style, i’ll copy your idea in my basic template. Most styles are never used. Tops.
Quite often models never get to lo, lately even less because its unusably slow. I started to work in indesign on screenshots for projects as a workaround to lo.

As I wrote, I created a folder of the styles I normally use in projects I do in LO. Here’s a screen grab of the folder contents.

My default working style does not have sections enabled. It does have dashes enabled but I don’t set any dashes styles for tags in SU either. That is done exclusively in LO. This keeps the setup in SketchUp very simple and allows me excellent control over the way the model is displayed in LO and makes using stacked viewports easier. Where I once might have had a dozen or two dozen scenes for a project, I now manage with as few as five or six.

Also, turning off sections doesn’t actually require a style change. One can just turn off “active cut” for all section planes that are affecting the view. The same style will still allow sections in other scenes where a section is set as active.