Unusual color picker issue

Just got off a support call about an issue with unusual symptoms. The ‘Selected’ color was showing as black instead of blue, in any template, and with any style selected. Going into the color picker and using the RGB sliders, gave these results:

0,1,225 - black instead of blue
255,255,0 - white instead of yellow
255,0,255 - red instead of magenta

Blue seemed broken, and acting like it was stuck on either 0 or 255. Moving the slider didn’t make it change the color.

Blue worked elsewhere, Marc’s shirt was a shade of blue, Materials could be set to blue. Even the color wheel in Materials was able to give blue. Only the styles color picker was failing.

I tried some usual fixes, OpenGL settings, recreating the preference files, etc. I had by that time searched the forum to see if there were similar reports, didn’t find anything, but by then I was thinking that it was a Windows issue and not specifically SketchUp. I was doing Google searches for any report at all, and hadn’t yet found a similar case, when at the same time the customer tried a reboot instead of just quitting SketchUp. That fixed the problem.

So, one of those cases where turning it off and back on again would have solved the problem! I thought I would post about it here, in case the problem happens to someone else.