Uninstall button greyed out in Extension manager

mac
uninstall

#1

Having experienced the memory leak problem with my new SpaceMouse Compact, I have had to uninstall it until 3DX come up with a solution. However, the plugin remains installed and I believe that may be the cause of the issue. As you can see below, the Uninstall button is greyed out and it doesn’t seem possible to get rid of it.

Anyone know why it should be greyed out and what to do in such a case?


#2

hmm… it might be that their SketchUp extension isn’t registering properly. Can you have a look at your Plugins directory and take a screenshot of the files related to the extension?
You can also try to zip up the files for the extension so I can inspect it.

This extension is installed as part of their installer, right? Did you try to run the uninstaller?

Workaround will be to manually remove the files from your Plugins directory if you can identify which ones are related to that extension.


#3

Could this be because on Mac they install into the global /Library folder instead of your personal ~/Library? Maybe the EM doesn’t understand that or there is a permission problem for you on that folder?


#4

On a PC it also installs into a shared ‘ProgramData’ subfolder rather than the main user’s ‘Plugins’ folder, so I suspect that is why the Extension Manager can’t uninstall it - because it’s loading from the non-standard shared-subfolder, not ‘Plugins’…
Several commercial Extensions do this - e.g. Twilight…


#5

If my and @TIG’s suggestion is right, there would be a sensible reason: an extension installed in the global shared folder affects all users but you are asking to uninstall it as a single user.


#6

Here’s what my Plugins folder looks like. Not sure there is anything in there that obviously corresponds.

I have now run the uninstaller but it didn’t remove this.


#7

OK, so any idea where I should be looking? TBH, uninstalling the SpaceMouse seems to have eliminated the memory leak issue so maybe getting rid of this is unimportant. (I bet as soon as I close this I get a memory leak again!).


#8

/Library/Application Support/SketchUp 2018/SketchUp/Plugins (note: this is at the root of your drive, not your personal library aka ~/Library).


#9

Just a though, maybe you already have uninstalled it and this is how the Extension Manager displays it throughout the rest of the SketchUp session. An uninstalled extension is still loaded so it would make sense to have it shown until SketchUp is restarted.


#10

Does this look like it to you? Should I just delete the folder contents?


#11

Yes, that looks like the place. You can turn off the extension by changing the file extension from .rb to .rb! or you could just delete the whole thing.

You will need to quit and restart SketchUp to make it unload the extension.


#12

Yup, that did the trick! All clean again now, hopefully.


#13

Any chance you preserved a copy of those files? It would be nice to inspect them…


#14

Here you go:

3DxSketchUp.rb (781 Bytes)

This is the file that failed the test. If you want a copy of the one that passed just let me know.

Now that the SpaceMouse is properly installed, the problems have all disappeared including the memory leak.


#15

Thanks. That file looked ok, so I’m not sure why it wouldn’t install…

Is the Uninstall button still disabled?


#16

I’m not sure it wouldn’t install. The problem was that it wouldn’t uninstall as the uninstall button was greyed out. I did manage to get rid of it eventually to make sure it wasn’t affecting the new installation that has since worked.

The problem turned out to be related to the firewall. You must have it turned off when you are installing. Presumably, the installation process involves a dialogue with a remote server and if that is being blocked by a firewall, the installation will fail. This may just be a Mac thing.


#17

But is the Uninstall button enabled after you reinstalled?


#18

Looks like not. I hadn’t checked as I hadn’t needed to. Strange.


#19

I dug into the source code, and found that the Uninstall button is disabled if the extension’s file isn’t writable. In this case it’s the 3DxSketchUp.rb. This can be either if the file is marked read only, or located in a place where the user running SketchUp doesn’t have appropriate access rights to.

Could you check if the file is marked read only?


#20

I know only Mac, but on it the 3dconnection extension installs in the shared /Library folder where indeed a user does not generally have write permission. I had to deal with this to let me disable the extension when the navigator isn’t connected.