Sketchup is broken, can't fix it


#1

When I launch Sketchup, I get a message that some of my extensions are in need of update. They’re pro-only plugins, so I tried to uninstall them. They disappear from the extension manager but the next time I try to launch, they’re always back.

This is only a minor annoyance, but after I leave the extension manager, Sketchup stops working. The model area turns black and the program stops responding.

Now… there are other extensions installed, including a popular Bezier extension and the very popular STL extension for 3d printing. I suspect maybe one or both of those is broken, but I cannot uninstall those either.

When I attempt to uninstall and reinstall Sketchup, the extensions are always still there. I would expect that when uninstalling Sketchup, the extensions would also be uninstalled.

Is it possible for me to just find the folder where the extensions are located and delete them manually?

Other users on the same machine (including admin) have the same problem.


#2

This sounds like the machine is set up for consistent use by all users, in which case you might not have permission to uninstall extensions from the programdata folder.


#3

Right; I should also have mentioned that I have tried all of this as both joe user and admin.I believe the plugins are somewhere in the user’s filespace, based on some info I read about a much earlier version of SU but I wasn’t able to answer the question, “where are extensions located (i.e., what’s the pathname to the folder they’re in) on the SU host machine?”


#4

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.