Unexpected file weight due to an image map

Hello,

I got a model someone sent to me, which is an urban scene (1) with an image map for the plan ground. The sketchup file is way to heavy regarding the level of detail (550 Mb !). And I noticed that its due mostly to the image. If I delete every objects and save the file with only the image ground (2) in it it still weighs more than 530 Mb. While if at the opposite I delete the image and save all the rest (3), it weighs only 20 Mb.
So how can a single image weigh so much ? I don’t know its resolution but it should anyway be compressed in the sketchup file, shouldn’t it ?

If you show the Colors palette, and look at the In Model materials, you can right-click on the big image and choose Edit. In the edit options that show up there is a button that will let you open the image in Preview. In Preview you could see how big the image is, and that might give a clue as to why it’s taking up over 500 MB. You could resize the image to something a lot smaller, save that as a new file, then back in SketchUp you can load the new file into that material.

Here’s a screenshot that shows the options I’m referring to:

image

The box with the arrow on top is what to click on to open the image in Preview. The Texture menu is where you can choose Load, to load in the new version of the image.

Thank you very much colin.
Now I managed to get some infos about this texture. Actually the “edit material” panel does not really learn about the size of the image as it gives a size in… meters, at the scale of the scene ! While the real information is not the meters but the number of pixels. And I discovered it’s given in the entity info panel. Screenshot below.
However the issue stills. 13900 x 9800 pixels (here) is great but should not weigh 550 Mb.
If you create a new file in photoshop, this dimension weighs around 390 Mb (without any compression !) so where are the 160 Mb too much ? :face_with_raised_eyebrow:

13925x9814x4 (32 bit image) is 546639800, which is 521 MB.

Photoshop may be working with it as a 24 bit image, which would come out to 390 MB.

SketchUp really only uses up to about 4096 pixels across, so your image has about 12 times as much detail as will be used.

Yeah but when I give to sketchup a 24 bit image why would it convert it in 32 bits ? Useless, as there is no transparency (alpha channel) involved. Anyway thanks for the tip about the 4096 pix limit (which is very low compared to real 3D softs). I still don’t understand why such basic settings are so badly managed in Sketchup. Mean you launch most of 3D software, managing image size / channels / etc is very clear and you easily know the limits of each parameter. Only Sketchup still keeps such an amateur interface where it’s a mistery to just know if an embeded texture is jpeg or tif. Sketchup developers and editors basic philosophy seems like to be : “users don’t know about how it works and the less they know, the better it is”.

Anyway thank you colin for your explainations.

Are you really using uncompressed bitmap images? You would get better results and a smaller file size by resizing them in a photo editor prior to import, and using the JPG or PNG format. SketchUp reduces, rather crudely, images to fit a 1024 x 1024 pixel square. If you have the “Use maximum texture size” box checked in Preferences>OpenGL, the largest map supported by OpenGL in your graphics card (max.4096) is used. TIG has created a “large image splitter” plugin that can overcome the limitation on some cases by breaking a large face to parts.

1 Like