Sketchup texture size limit reached (from drone survey)

Hi there,

i have read that Sketchup can only import a maximum texture size of 4096x4096. This came from an official post back in 2012. I am a bit desperate now, but i am wondering if there is a way to go beyond this limit of 4096x4096… from what i can see in sketchup, i see no why to increase this.

I am using this for professional use, and I am trying to import a very large landscape model which was surveyed by a drone, which includes a large orthomosaic jpeg which needs to be imported. Orthomosaic files go well beyond 4096pixels, and due to the scale of this site model, it has turned out very blurry… I do not know why Sketchup has this 4096pixel limit as it really hampers importing large drone surveys into the model… 3DS max and similar programs do not suffer from this limitation.

can anyone help or advise what i can do here?? the only thing i can think of is to somehow split up the site drone survey into 4 parts outside of sketchup, and create 4 new Orthomosaic jpegs for each new part, then separately imported and piece together everything in order to overcome the issue. cant think of any other solution… !
this is a real pain.



You ask an interesting question.

First; Yes, SketchUp can import textures at above 4096x4096. There’s a setting called “enable maximum texture size” which will increase that pixel value to …whatever your video card RAM can handle. I have a GTX1070 (4gb RAM , i think) and I can get up to 16,000x20,000 and it handles that size fine. What size are you intending to import?

big image

The interesting part is this:
I created a test image in Adobe Photoshop 8000x8000 size which has a few lines and dots of 1px width. I saved as a JPG. When I open in Photoshop, the 1px dots are crisp and clear…there doesn’t seem to be any antialiasing (smoothing effect). However when I open in Windows Image View, or SketchUp, there is antialiasing…the dots and fine lines aren’t quite as crisp.

The problem is this: An image with pixel dimensions could have a real-world width of 1metres wide, or 100metres wide, or 10,000 metres wide… SketchUp doesnt have any reference for scale, so it will need to scale it to your chosen (somewhat random) size and, therefore, antialise the pixels.

Some other software has options such as “1 pixel = 1 centimetre” when importing images, but SketchUp doens’t have this option as far as I’m aware.

Another thing I’ll add is that the images you’re importing appear to come from photogrammetry. I also use that sort of data in my models. There are often settings to export each triangulated face with its own unique “baked on” image. This means that you dont actually import one image of 8000x8000 (or more), but instead you import a large number of unique images (maybe 100s or 1000s) of a much smaller size. (depending on the triangulation granularity). This is likely true if you are importing OBJ or similar filetypes.
If you are not using photogrametry software to generate a “baked” image, then you will need to import a large 2 dimensional image. Then what will happen in SketchUp is that you will import the 3d surface (triangles, probably) then the flat image… and you will need to Drape that image down vertically…in doing so, you will find a lot of 3d faces end up with distorted images because they are stretched from 2D into 3D.

So…The correct and ideal solution is to import a Drone Survey using a program that can assign each bit of the aerial photo to its own triangle. Trimble Realworks will do this.
The second solution which you have mentioned is to import a high res image but cut it into four pieces. If you do this, then it is necessary to create an image Grid that you can snap to (using a CAD or GIS program) for optimum accuracy.

Or use @Aerilius image splitter:


thank you for your response. much appreciated.

I am using a rtx2080.

here is another example of whats going on. Right image is from an typical image viewer software, left is within sketchup. Exact same file. confirming maximum texture in open GL is ON.

I did check the resolution, and it is telling me it is coming in as 8192x8192. But when i compare sketchup with the image viewer software, it is more blurry in sketchup for some reason, and by quite a bit too.

your investigation seems to explain it. Perhaps if i can import a 16k texture, this can defeat the issue by pure brute force? the 16k pixel image wont be as crisp as being read in another program, but will be better a heck of a lot clearer than the 8k pixel texture i am using in sketchup.

and confirming that this model was created using photogrammetry software, so I have 1 massive image which is flattened then baked onto the model.

I cannot use the drape method due to the fact that surfaces within cut in areas do not get textured correctly. ie under tree canopies.

if i use Trimble Realworks, wont i end up having 1 million textures in my Materials tab? each for every triangle within the model? I dont have Trimble RealWork at this point in time.

I am not the owner of the survey software (Pix4D), this is done by another company. I have asked them to split the model into 4 parts for me, and i should be able to import each section, and piece it together accurately based on the existing geometry of the model, exactly like one would piece together a real life puzzle. at least in theory it should work.
or again, perhaps just use a 16k texture instead of subdividing the model? seems like this is the easiest solution?


thank you for your response. the image i am working with cannot be cut up within Sketchup, or this will mess up the texture mapping which is done within a different program. if that makes sense.


yes this has been done. my image is very large and it is still blurry. this is the issue.


Do you get any difference if you reduce the anti aliasing level? If you’re on a HiDPI monitor it’s debatable whether you need any antialiasing at all, but you could certainly get away with 2x or 4x. If you are set to 16x, the image is being handled as 65536x65536. I don’t know enough to know where it might be handled at that size, but it would be worth trying a lower antialiasing setting anyway.

From my experience, “maximum texture size” is limited to 4096x4096 pixels. If I import anything larger than that, SketchUp downscales it. I imagine that’s happening with you two based on your experience of seeing a blurry version right after importing.

No that doesn’t make sense. What format is the image? 8096x8096?

You need to import ‘as Image’, then run the image splitter and explode afterwards. You than have multiple textures, which you can stitch to ‘drape’ or project on the surface area.

here, i use a 6000x5800 pixel image, import as image, do the split, trace the divided image outlines, drape those on the area surface and then paint the divided area’s with the images’s textures:

drape method does not work. Drone survey data includes areas below tree canopies… and under roofs of houses etc. the drape method is too primitive. For example, if there is a large sun shade roof, and below it, paving on the floor. the drape method will apply the texture to the roof of the sun shade, but will not apply texturing to the paving surface below that roof.

I have ruled this method out from the beginning because of this.


If sketchup downscales it, why doesnt it mention it has an upper limit for importing textures? instead it simply states “use maximum texture size”. which you would assume would actually use the maximum texture size. furthermore sketchup even confirms that the imported image is 8192x8192pixels when selecting that texture. again this would be completely untruthful if the hidden limit is indeed 4096x4096 pixels.

but indeed, the imported image is not truly 8192x8192pixels … and i think AK_SAM many have figured out why.

still trying to debate the best method for importing such a file to overcome this hidden limit.


Maybe use the scan essentials extension?
There is a free trial

i have tried setting AA to the lowest setting or off. No help unfortunately. i think this only works for construction lines, not images, as i see no difference. I have tried on other HD monitors and 4k monitors.


I believe it’s because the maximum is 4096x4096. In my experience, if I uncheck “Use maximum texture size” it displays even lower resolution than the 4096x4096. I can’t get anything higher to display without it downscaling. Anything I input up to that size displays perfectly without any unwanted resizing going on in SketchUp.

yep. seems this is true. Even though sketchup says “use maximum texture size” and also shows the correct resolution in the properties tab… BUT these are both false. as it scales down to 4096x4096…
they should really just clearly state that 4096 is the max to avoid confusion.


1 Like

AA doesnt really make a difference to images…i dont know conclusively if it does anything or not, but i didnt see an improvement turning it off. Remember you also have Antialisaing and Quality settings within your NVidia Display Properties…turn it to Quality and see if that helps.

It might be possible for Pix4d to generate a flat "unwrapped " image that can be draped; it will look distorted when you view it in 2D but appear correct in 3d…but it still wont cover the areas under tree canopies. For that I beleive you need a triangulated image (unless there’s a differnet format such as a raster(3d) TIF such as the kind that GIS uses; but Im not sure that SketchUp recognises the 3d pixels)

Good practise is to slice the model up anyway as it will be pretty hard to handle all in one SketchUp view. Editing and snapping becomes very problematic if you cant isolate parts of the model; EG, SU will try to snap to everything that’s visible. Snapping tiles like a jigsaw puzzel is no problem (but good practise is to ask the surveyor to include a common base point or grid as a snapping reference)

& yes, if it is triangulated then you can have: Either 1000000 tiny images, Or the same image used 100000 times with different positional settings. Each survey/photogrammetry software will offer different options for this. In both cases, it’s 90% certain that you wont easily be able to edit the image or mesh in SU (eg by using sandbox tools) because the image will lose it’s position and scale very easily, and become distorted.

With scaling down from 8000x8000px down to 4096x4096 you would expect some loss of quality, but SketchUp’s quality loss appears quite substantial. It’s compressing the image quite a lot, and/or possibly not using a fantastic resampling algorithm. Could there be an adjustment in quality setting somewhere (a Tick box saying “Use Maximum Texture Size” as well as "Use High Quality image sampling’) .

I was really hoping that Trimble’s purchase of SketchUp would have bought with it some improved tools around the handling of imported survey and GIS data. We havent had any movement in that space for years but those datasets are now totally common in the AEC industry (the manual theodolite-based methods are history). Modelling directly over top of 3d scanning would be a natural workflow for SketchUp to master. Maybe Realworks could even become part of the Pro suite (like Seifara is)???

I’ve attached a couple of images of a project I modelled recently using point cloud scanned data. The scan is maybe a billion coloured points, very high res (trimble SX10 gear, plus a bit of manual patching with the GPS RTK). It looks amazing in Realworks…incredibly lifelike, but all i can do is bring in basic “traced” linework from the model (highlighted in pink). Its not terrible, but it would be nice to bring points into the SketchUp model. Tracing linework is also a bit error prone and theres manual effort and cleanup involved…not ideal for critical/structural design.

I have some examples of modelling over top of high res photogrammetry as well…maybe i can share those on Monday. From memory we did a tile about 200x200m at 5cm pixel resolution, then a bunch of surrounding tiles at 25cm pixels.

That would be the Studio suite, then