Unexpected File Format!


#1

Continuing the discussion from Problem with Open/File in SketchUp 2015:

[quote=“mahmadio, post:7, topic:12471, full:true”]
Unexpected File Format error! It had been hours of work :pensive:
Really need help!
[/quote] Please explain your problem more clearly…
Here’s my guess…
You made a Model.
You saved it.
Later on you tried to open it and it fails with this error message ?
Either the Model is corrupted or you are trying to open a BackUp SKB file rather than a SKP ?
Did you have it set up to make BackUps ?
Renaming a .SKB as a .SKP it should open in the newest version of SketchUp…
How are you trying to open it ?
Can you open a blank Model and Import the ‘faulty’ SKP into that etc…

Help us to help you…
We are having to guess too much here…


#2

Thanks for the reply
Actually I worked this file on another computer! I put it on flash drive and brought it to work.
I don’t have access to the first computer any more.
The thumbnail of the file is shown but when I open it, the “unexpected file format” pops out.
I tried the importing file but it didn’t work. It gives the “file not found or invalid” error! :frowning:


#3

Were the SketchUp versions on the two computers the same ?
If you made it in v2015 and now try to open it in v2014 it is not valid…
Install and use v2015 [Make] to open the SKP file, then you can use Save_as to save it as any earlier version you like, if that’s what you prefer to work with…


#4

Actually the Sketch Up at work is 2015! It seems it is not also the problem! :frowning:


#5

I’m afraid you are in a bind.
If you had access to the original SKP, or SKB or an AutoSave file perhaps something would be retrievable…