Unexpected File Format after saving and reopening a .skp file

I have built a model and successfully save it into a .skp file, however, after I reopen it, I got an “Unexpected File Format” error. I tried everything I know, including importing/renaming etc but the error still exists.

Is there anyone who can help me find why it happens, and even fix it? Thank you so much!

The file is attached in the following address:
https://1drv.ms/u/s!AjeliuYcobjFg6wvf19Hy8P8a-dopQ?e=Tb5kZj

Is there a .skb (SketchUp back-up) file in the location that this file was last saved?

If there is, change the extension to .skp and try to open it.

Thank you for your answer. I tried, but the renamed .skp file from the .skb one still cannot be opened, the error is the same, “unexpected file format”. Very very strange.

I tried to recover the file, but couldn’t get anything from it.

Thank you so much! But it looks like that the thumbnail of the file can be seen, which shows the model I built. It at least means that the content of the file can be parsed in some way although the file cannot be opened.

I saved the file in a cautious way, and did not encounter anything like SketchUp crashing. So I am guessing there may be bugs in the software when saving. Look forward to your investigation about it.

1 Like

Where are you saving your file?
One of the most common reasons for this issue is saving to a network drive or synced folder.
It is best to save and work locally and only make a copy as a backup to a non local drive when the file is closed.

Local drive exactly, what’s why I feel it so strange. I checked lots of posts on the Internet, and feel that this issue is not that rare. Cases like mine exist, and nobody gives a solution.

Do we still not have an answer on this issue? i have been looking on the internet and see it a common issue.
I see on a different post you have said about being able to recover the components from the corrupted file, Is this something you can do for my file.

Yes, I can try.

Hi Colin,

Thanks for getting back to me, I have 3 file formats that are listed but cant seem to upload.

I have uploaded to wetransfer and you should be able to access them though the following link.

If this is not acceptable please advise.

As usual, I only recovered the components. There won’t be anything in the scene, but the file includes 4,546 components.

Thanks Colin that’s very helpful.

Any Idea what caused this to happen? all files that I was working on were on the local drive not network or external drive.

Thanks

URGENT HELP REQUIRED! Submission in less than 24 hours! Same error, is it possible to recover components?? @colin

See my reply here:

Hey, @colin I’ve encountered a similar problem. I would really appreciate it if you help me recovering this file. Thanks.

The model seems to only have a few dynamic components in it, and a few people recently have had the same components in their file. Are you following a course, where many people are doing the same exercise?

I could only recover the components and materials. Here’s the file:

2 Likes

Hey, @colin I’ve encountered a similar problem. both my SketchUp and auto save files arent opening due to this error. I would really appreciate it if you could help me recover this file. Thank you.

Autosave file Recovery

I think most components and materials are recovered, but the scene is empty:

Hello sir, could you please help me recover my file its pretty small (1M) but very important to me, thank you so much!!

I tried the file, but unfortunately most of the file is empty bytes. There isn’t anything in the file to recover.

1 Like