Unexpected file format help!

Hi There

I have just started getting the dreaded - unexpected file format - message when trying to open a model.

Have tried re-naming the skb. to skp. but same message appears.

Anyone know how i can try fix this as it contains hours of work!

Thanks in advance

Where have you been saving your SketchUp files? Hopefully not Drop Box or some other cloud location but on a local drive (installed in the computer).

Unfortunately corrupted SketchUp model files are rarely recoverable. You could share it and someone could look at it to try. There’s always a small chance but I wouldn’t hold my breath.

Yes been saving it on my local drive not any cloud sharing. I’ve tried to upload it but unfortunately the file is too big, any ideas how i could make it smaller/upload it another away?

Upload the file to a file sharing service like Drop Box and share the link.

Just don’t save your working files to the cloud. This seems to cause a lot of problems.

ok thanks for your help

You need to open up the permissions.Currently the file isn’t available.

that should have fixed that thanks again

Unfortunately I can’t open it either. It might be that @colin has access to some options for opening it, though.

I am only able to recover components from the file, but maybe those will be of some use.

Terrain_recovered.skp.zip (9.3 MB)

1 Like

Dear Colin, Dave
I am also having the same issue as Thomas and was hoping if you could help recover some of the files (fingers crossed!). I’ve tried renaming the file as suggested and I’ve also copied the file elsewhere and try opening them but neither work.

Hopefully you could help me out:

I couldn’t recover anything in the scene, but all components and materials are there.


Thanks for replying Colin.
However, when I’ve downloaded the file it seems empty?

As Colin told you, “I couldn’t recover anything in the scene, but all components and materials are there.”

Look in the In Model components. There are 324 components in your model. There are 184 materials in the model, too.

can you help me open this file i cant open it with unexpected file format

Good news:


I am not sure what the issue was, but think that one of the materials had issues. A lot of your materials have strange names, perhaps unicode. That shouldn’t matter, but it makes me wonder where the materials came from.

thanks q brother for help

some of my symbol i am download it for china model website

I don’t know if that matters, but if you have links for those models, that may help.



i really need your help