Unexpected File Format after saving and opening a .skp and .skb file

I saved the document from 2021 to 2020, as a prompt to save the file to 2020 appeared while doing the model. But when I tried to reopen the file, it says unexpected file format. I tried the backup file from .skb to .skp but it did not work. Please help me recover the file. I have a presentation due in 2 days, I’ve been working on the model for 2 weeks.

The file is saved here: sketchup - Google Drive

Thank you so much!

It´s a big file, I couldn’t open it I guess it must be corrupted, I´m sure that @colin will be able to recover it.
Were you working from a external device or from the cloud with your file or was it in your local storage device?

1 Like

Hi! Thank you! Hopefully @colin will be able to help. I saved it on my laptop local storage. The thumbnail still shows the model, but unfortunately i can’t open it

Hi @colin! Would you mind checking if you can recover the file, please? I badly needed to recover the model. Thank you in advance!

Be patient! It’s just after 3:00 AM where Colin is. I’m sure when he gets in to work he’ll look at your file.

Oh. Sorry, my apologies. I was just panicking. Will wait for Colin. Thank you!

I am awake now, but unfortunately couldn’t recover anything useful from either file.

Hi Colin! It’s very unfortunate but thanks for your reply. Appreciate it!