Uncheck “Preserve Scale on Resize” randomly changes scale of viewport

I adjust perspective model views by resizing the viewport, and then when I want the view to be larger, I of course uncheck “Preserve Scale…” before stretching the window. Rather than staying still as I would expect, the viewport resets to some random smaller scale, thereby undoing my adjustments. This has happened to me for years and I have always assumed it’s a bug. I have seen other posts about this issue, but no resolution. Is this a feature I just don’t understand? Why on earth would you want the viewport to leap to a random scale?

1 Like

When you uncheck the preserve scale, it uses the extents of the LO viewport box to fit the camera extents from the SU scene in the LO viewport. So in the future, you can either make sure to “zoom in” on the perspective SU scene to fill your LO viewport, or you can utilize a clipping mask instead of using the “preserve scale” checkbox.

@nmason Thanks for the response. What you say certainly makes sense. This helps me understand that the scale it leaps to is not random, though I still wish it did not leap at all.

It isn’t random. Set up the scene appropriately in SketchUp and then you won’t need to use Preserve Scale on the perspective viewport at all.

If you’re not familiar with clipping masks in LO, they can be very handy on perspective scene viewports

@DaveR what do you mean by “set up the scene appropriately?”

Set the camera in the scene to show the model from desired angle and zoom in. Very often when I see LayOut files from other users, they’ve often set up the scenes so the camera is placed at a long distance from the model and/or the area of interest is not in the center of the model window.

You probably need to zoom in and center the model in the model window. Of course it would be easier to give you more specifics if you share your LayOut file.

I’m not able to share the particular file I’m working on now because of project privacy concerns, but the scale change happens whether or not the model subject fills the scene frame, or is zoomed out in the scene. And there are times when being zoomed out is “appropriate” and I still want to increase the size of the view on the sheet. Either way, it feels like a glitch that unchecking “Preserve scale…” should automatically change the viewport to a new scale and camera position before manual adjustments are made.

It’s not a glitch or bug. When you uncheck Preserve Scale it’s doing what it’s supposed to do by resizing the model based on what you did when you resized the viewport.

Use the clipping mask suggestion instead, then.