Unable to work with a selected set of entities

intel
graphics
driver
selectiontool
hdgraphics

#1

I’m new to sketchup so forgive me if this is a really basic user error, but I’ve spent about an hour searching without finding another thread that answers this particular problem. I can’t seem to get the selection tool “box” to work properly. Here are some examples of what’s happening (or not happening):

  1. Highlight set of entities within the selection tool “box” by dragging upper left to lower right.
  2. Press “delete” button.
  3. Selection set no longer highlighted, entities not deleted.

Also:

  1. Highlight set of entities crossed by the selection tool “box” by dragging lower right to upper left.
  2. Press “delete” button.
  3. Only one entity within the selection set is deleted.

Also:

  1. Highlight set of entities with the selection tool “box” by dragging either way.
  2. Click “Edit” drop down menu.
  3. “Make Group” and “Make Component” are not available (those buttons are shaded or “off”).

Also:

  1. Highlight set of entities with the selection tool “box” by dragging either way.
  2. Click various tools (e.g. Scale, Move, etc.)
  3. Click within the work area or on the selection set (either way) to use the tool.
  4. Selection set no longer highlighted, tool command not available.

Hopefully these examples will be enough for someone to diagnose the problem, whether it’s with the software, or with me.

Thank you.


#2

Are you letting go of the mouse button after making your selection and before erasing or trying to make a component?

If so, it might be a problem with your graphics card driver.

See if you can update the drivers. You’ve quoted dll file names, not the graphics card name, bit it looks like Intel. If it is old, it may not support OpenGL 3.0 at all, which SU 2017 requires. If it does, often only the latest drivers provide good enough support for it.

Search this forum for ‘Intel graphics driver’ to find out more, and for ‘how to find your graphics card details’.


#3

I’m using a laptop that’s about four years old, so you may be onto
something. I’ll do those searches. Thanks.


#4

Just realized I failed to answer your first question. I’m using a touch pad
instead of a mouse, but yes, I lift my finger (“release the mouse button”)
after making the selection and before pressing the delete button or
clicking a tool.

Following your advice I found this information on Sketchup’s “Open GL
Details” popup:

Vendor: Intel
Renderer: Intel® HD Graphics Family
GL Version: 3.0.0 Build 8.15.10.2266

So it appears the driver does support Open GL 3.0. While researching how to
check if an update is available, I came across a warning that updating the
driver on a laptop can sometimes cause the computer to run hot, meaning the
fan runs much more often and depletes the batteries much faster. They also
said it could damage the computer. So I’m a little leery of that.


#5

See if there is a later version of the driver on your laptop vendor’s website. That should be safe.

Even if the current one ‘supports’ OpenGL 3.0, the support may not be complete enough for SU 2017.

See for example this post:


#6

Went to the Samsung website and it appears the only driver update available
there is the one I already have. Since they state at the Forum link you
provided that a 10.18.10.4061 or higher version is required, it seems I’m
out of luck with this laptop. I am able to select entities one at a time,
but that’s pretty tedious and time consuming.

Thanks for your help.


#7

I’ve seen one workaround on the forum for a slightly different problem - long wait after single click to select. Instead, R-click, then press Esc. But that may only work for a single entity R-click and for those whose driver problem causes a LONG… wait for response to a left-click.

Don’t know if it will work for you with a Window or Crossing select, but if it does, it might save you either going back to v2016, or getting a new laptop.

v2016 only needs OpenGL 2, and at a pinch you can even turn off hardware acceleration altogether, though that will hit performance in larger models… v2017 NEEDS the accelerated graphics, so you don’t have that option. You don’t say which year version of SU you have, but I assume 2017 if you’ve just downloaded it.

On top of OpenGL driver issues, Microsoft seems to have issued several recent Windows Updates that have caused problems to resurface, but for Windows 10 not 7.

However, there can be other display problems if your driver support isn’t good enough, and it might be worth trying the alternatives I suggest above - downgrade to 2016 Pro, or new laptop - if you need it for paid professional work. You’ll get the money back in improved productivity, lack of wasted time, and avoidance of frustration.


#8

Yes, I’m on the latest version of SU 17 with the update. Going back to 2016 might be best, because you are certainly right about the poor productivity and frustration.

But your suggestion about right clicking led me to learn that I can select a single entity, right click, and chose from one of three selection options. That allows a group selection of a surface and its perimeter lines, or else all entities connected to the original selection. Then I am able to work with the selection. Although right clicking and choosing from the drop down menu options is more effort than a simple click and drag, it’s still a big improvement over selecting everything one at a time. I’ll try it that way for a while before going to 2016.

Also, I have been lusting after a laptop with solid state memory for a while. Maybe this is just the excuse I need… :slight_smile:


#9

Well you could follow Eliza Doolittle’s father’s song (from My Fair Lady) “When temptation comes, I give right in”!


#10

While you’re out shopping for a shiny new laptop, consider picking up an inexpensive three button scroll wheel mouse, they make Sketchup a pleasure to drive.


#11

I knew someone would say that when I typed the words “touch pad.” But I’ve been using a pad exclusively since back in the mid 90’s. A three button mouse with a wheel would probably speed things up, but I’m pretty darn fast with this pad if I do say so myself. Probably the main limitation on speed at this point is my brain, which seems to be the case more and more as I get older. (Plus, the older I get the more I like working in an easy chair, and a pad is better for that.)


#12

Yes indeed. “Everything in moderation, especially moderation;” that’s my motto.


#13

Is not the limitation constantly switching to the orbit tool to get around your model?

Edit: That was meant as a genuine question, not criticism. I am forced to use the trackpad on my laptop sometimes and I find navigation cumbersome. And my brain is a real limit too🤔


#14

That is a very old driver, even for running any version of SketchUp 2013 onward. It’s just too old. All the builds are now in the 4000s.

I’m running an older machine than yours (like 7/8yrs old) and even it is running driver v 8.15.10.2869.

You can always roll the driver back if that becomes the case.

How so? Do you a have a link ?


#15

I guess “ignorance is bliss” having not used a mouse with SU before. But I pinch to zoom in and out while using the Orbit tool, and I use that tool to “yaw” and “pitch” of course, so that covers all of the motions needed except for Pan. Probably later when I learn the software better it will begin to slow me down, but for now, as a slow newbie anyway, it seems okay.


#16

It was a SU user comment on the Forum, at the link John provided above. My ultra geeky brother (programmer since the late 80’s) said I shouldn’t worry about it because the commenter was probably dealing with a unique configuration (perhaps had done some other customization as well).


#17

The thread starter in that topic bought a legacy (G41) machine that is older than mine (and mine is pre HD graphics.) I re-read the whole thread, and there was nothing in it that suggested dire consequences for updated a graphics driver.

If your brother’s geeky get him to do it for a beer or two. :wink:


#18

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.