Unable to smooth edges of imported Collada files

Hi. When I import collada files into Sketchup Pro 2019 they seem to come in with all edges visible. I have tried ticking and unticking the merge coplanar options at import to no avail. Once imported I am not able to smooth edges either. Is anyone else having this issue?
Collada woes.skp (6.7 MB)

Turn off profiles in the style.

When I open your file I see a lof of unsoftened edges as you report.

After cleaning up the coplanar edges and softening the rest.

I suspect that these were imported without merging coplanar faces. ThomThom’s CleanUp3 made quick work of it, though.

The styles I commonly use for export need the edges turned on so this isn’t a solution for me I’m afraid.

Ooh this looks promising. Is Thom Thom’s cleanup 3 a plugin? I did import with merge coplanar on. I tried every combination of the options available for import.

It’s an extension available in the Extension Warehouse.

Thank you I’ll give it a try- this could save me!

You can do it manually.
Soft

HI this worked on the sink but only partially on the bowl for me. I hadn’t tried exploding before. Thanks. I’ve not had time to restart sketchup yet to try clenanup plugin (deadline) but this is a quick partial fix.